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PURPOSE 
 
Firstly, well done for even starting to read this manual. In it I have always aimed to 
describe things as plainly as possible but of course the many hours I have spent 
programming In My Diary probably makes me a bit biased regarding the ease of using 
it, so I hope I still manage to make some sense and pass on some useful advice to 
you through these pages. 
 
My aim when setting out to create this diary, and my continuing aim as its facilities 
have gradually increased, has been to present the user with a product that, on the 
surface, just looks like a standard simple paper diary. Although it is of course much 
more you can, if you choose, operate it exactly like that: turn off audible and pop-up 
alarms, and it becomes no more than a simple diary where you click over the day you 
want to add something and type in the box and save. 
 
For those that need more, you can create To Do lists that constantly remind you every 
day what tasks still need to be done, warn of forthcoming anniversaries and events 
(with email reminders also), store all your contacts, store all the passwords you use 
elsewhere in one secure place, keep a daily journal, set tasks to run on your computer 
automatically when required, use as a memory-aid clock for those with dementia 
related illnesses etc. etc.   It is up to you how much or how little of its facilities you 
choose to investigate but, however you use it, I hope you find the diary to be useful.   
 
The diary allows for daily activity and daily journal to be stored, either one-time or 
repeating events, and for advance and real time notification of the events to be given 
by pop-up message (with audible warning if set), email if you wish to you or with bccs 
to others. Anniversaries you enter also appear as pop-up messages. There is a slight 
difference in the way pop-up alarms for anniversaries appear compared with diary 
entries. Diary entries are usually associated with a specific time, whereas 
anniversaries are just associated with a date. If you turn your computer off and on 
each day, any early warning of EVENTS on future days or later that day, or events 
that have just passed (but where you have not yet been notified) will pop up as an 
alarm and will stay on the screen for 15 seconds. The same alarm will not appear 
again. 
 
If you get an ANNIVERSARY or a TO DO warning as you open the program it will again 
stay on screen for 15 seconds. If you click the OK button to say you have seen it, it 
will not appear again but if you do nothing if will appear again each hour that day until 
you acknowledge the message. This new feature (May 2017) is meant to help users 
who leave In My Diary running 24/7 where a one-time pop-up warning (at midnight) 
may be unlikely to be seen.   
 



 5 

INSTALLATION  AND FIRST USE 

Download the correct installer for your operating system and run it. If this is the first time 
you have used the program you will be asked in what language you would like the text to 
be displayed. This can be changed later at any time from the Language menu.   

Standard Fully-installed version 

 Windows 

After installing on Windows, a shortcut called InMyDiary will have appeared on your 
desktop. Double-click this icon to first run the program. If another user on your 
computer has already installed In My Diary then the shortcut just mentioned will not 
be on your desktop. You should install In My Diary from your own user account. 

MacOS 

After installing on MacOS you will need to navigate to your applications folder, open 
the InMyDiary folder and double-click InMyDiary to run the program. Whilst in this 
folder, you might want to make an alias of the InMyDiary application and put it on the 
desktop. Clicking this will then always load your default file.   

 Linux 

After installing (native) on Linux the program will be found in the Office section of the 
Applications menu. Click this menu item to run it. If you wish to install the Windows 
version using Wine, you will need to set the executable property of the installer once 
you have downloaded it. Go to the folder where your browser stores its downloads 
and right-click over the imdsetup<version>.exe file. Click the permissions tab and 
click the executable property box. If installing using Wine, each user must install their 
own version of In My Diary. This is not necessary when using the native version. 

 After In My Diary is first run you will find in your documents folder another folder 
called 'In My Diary' containing: 

1. a file called Diary.ads. This is your default blank diary. 

2. A folder called backups. Every time you save your diary, a copy of its condition 
when last opened will be put into this folder. (Only one backup per file per day can be 
saved) 

Linux installations please note: 

If you install the native version, the name of the folder in Home/Documents will be 

'InMyDiary' (no spaces). If you install the windows version using Wine it will be 'In My 

Diary'.   

 The file diary.ads is a default 'starter' file and the program will always try to load this 
first unless you change the name of the default file from the Options menu. You really 
MUST do this to avoid possibly overwriting your data in the future if you need to 
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reinstall the program to recover from a problem. Renaming the default file explains 
how to do this.   

Self-contained version 

This comes as a zip file and, on all three platforms, you should just unzip the archive 
and place the folder wherever you would like on your computer. The default names of 
the Self-contained folders are IMDiary (on Windows), IMDiaryM (on MacOS) and 
IMDiaryL (for Linux). These can be changed to whatever works for you, and you can 
have as many copies of the Self-contained version as you wish to run different diaries. 

The first time you run the self-contained edition on MacOS (Sierra onwards) you will 
get an error message. You will need to drag the InMyDiarySC app OUT of the folder 
(maybe to the desktop) and then drag it back in to the folder.   

  

DIARY FILES 
 

Opening a SELF-CONTAINED diary file   
 
To run the program (open a diary file) when using the self-contained edition you 
should ALWAYS do this by opening the IMDiary folder and double-clicking the 
InMyDiarySC.exe file. This opens the diary.ads file in the data folder and this is the 
ONLY diary file that should be opened when using this SC edition. If you need other 
diary files, you can make copies of the IMDiary folder, or consider using the Standard 
version.  

Opening a STANDARD VERSION diary file on Windows  or Mac 

 There are two ways of opening a diary file. You can double-click over an .ads file that 
you have saved and it will open in In My Diary, or you can double-click the 
InMyDiary shortcut icon on the desktop (windows / Linux wine only, unless you made 
an alias as described in the Mac installation section), in which case it will open your 
default diary file (after first installation this will be 'diary.ads' but you can alter it from 
the options menu). The file you have opened will minimize to the bottom-right task 
bar as it loads and run in the background. Click the icon to open up the diary window 
(it may be among the hidden icons).  

Opening a STANDARD VERSION diary file on Linux . 

Once installed the program will be found in the Office section of the Applications menu. 
If you save a file to anywhere other than the default diary.ads file it can be opened by 
double-clicking it but you will first need to tell the file that In My Diary should open it. 
To do this, Right-click over the .ads file you have made and select 'permissions'. In 
the 'Open With' tab you will need to select 'inmydiary' from the list of applications. If 
this does not appear in the list then you will need to navigate to the program and 
select it from there. It is in usr/bin/inmydiary. Doing this for the first time should then 
mean that anytime you click an .ads file In My Diary will open it.  
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Renaming  the default file 

Firstly you need to make a file to use instead of your default 'diary.ads' file. This is 
best done by opening the program and using Save As... to make a new diary file. You 
can save this file anywhere, but remember where you save it.  

Then go to Options > General options, click over the file you have just saved and 
DRAG it to the default diary file text box there. When you open In My Diary the next 
time (from the shortcut on your desktop) it will open the new file by default. You can 
of course also open the file, or any other file you have saved, by double-clicking it 
directly. 

A note about saving  

It's worth pointing out how things get saved as you use In My Diary. Your diary file 
(the events, contacts, Notes, To Do tasks and day highlights) have to be saved by you 
if you have made any changes during a diary session. If you do not save the diary file 
and try to close it, you will get a warning message. However, you can instruct the 
program to save your file any time a change is made to the three areas mentioned 
above; this is done from the Options menu. 

All other changes you make - to your Journal, Password Manager, Anniversaries and 
Special Day data are always automatically saved whenever you close the window 
where the change is made.  They are saved and stored INDEPENDENTLY of your diary 
files. If you are using the standard version of the program, Password and journal data 
are in two files at My Documents/In My Diary/journal (and PW). Anniversaries and 
Special Day data are stored in an AppData folder called InMyDiary. Don't worry if you 
don't understand about these details, but what you should remember is that these last 
four will be accessible from ANY diary file that you create while you are logged on as 
user. Other users, logging on to their own area of the computer will have their own 
versions of these four sets of data. If you are using the self-contained version of the 
program, everything is stored in the InMyDiary folder you create, but the same rules 
apply about automatic saving. 

So what this means in a nutshell if you are using the standard version - Suppose you 
want to give your diary data to someone else who is using a different computer or 
logged on to their own area of your computer. If you give them your diary file (by 
email or across a network for instance) they will only see your Events, Contacts, Notes 
and highlighted days. When they open your file, any anniversaries or Special day 
changes will be ones THEY have set or made, not YOURS. Similarly, any Journal 
entries and passwords stored in the Password Manager will be ones they have created 
- not yours.  

If you are using the self-contained version and you want to give someone your dairy 
data, only give them the "diary.ads" file, not the whole InMyDiary folder. Of course if 
you want them to be able to open your Journal or Passwords, then you WOULD give 
them the whole folder. 

Making people's birthdays appear in your diary is affected by this difference in saving. 
If you add someone's birthday to the Anniversary section, that will then appear in ANY 
diary file YOU create on THAT computer, but will not be seen by someone opening 
YOUR diary file on THEIR computer. If you instead add their birthday in the Contacts 
section of a diary file, and tick the box 'Show in Diary', the birthday will appear in 
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ONLY THAT file when you open it but it will appear when that file is opened on ANY 
computer.       

  

USING OVER A NETWORK OR INTERNET HOSTING 
FACILITY (eg. Dropbox) 

In My Diary can be used over a network and from version 3.61 this facility improved 
significantly.  

If you are using the self-contained version then you should keep your ENTIRE 
IMDiary(L,M) folder in a place that is accessible on the network (so if using such as 
Dropbox, keep the whole folder in your Dropbox). This will mean that all elements of 
the program are available to you from all sources.  

If you are using the standard version then you only need as a minimum to have your 
diary file accessible, but if you want to share other elements (Journal or Password 
Manager) these can also be placed in a shared network folder, but you need to follow 
the instructions in OPTIONS below to set the location of your chosen journal and 
Password Manager folders. Please be aware though that Anniversary data and Special 
Day data and your General Options apply only to the specific computer you are using 
and are not shared over the network.  

It is possible to set In My Diary so that, when used over a network, any changes 
made on one computer can almost instantaneously reflect in any other computers that 
are accessing the same diary file at the time. This is achieved by using a combination 
of having Auto-Save set (see Options) and having Auto-refresh over network set 
in the Memory-aid clock Options. If only one computer should be allowed to save 
changes (for example, if the other is being used as a memory-aid clock display) then 
Auto-save should be set on just that one, but Auto-refresh over network should 
be set on the receiving computer.   

  

 

GENERAL DETAILS  

The diary can be resized by dragging the bottom right hand corner of the window. 
Once saved the diary will open at the size it was when previously closed.  

Moving to other pages, whether looking at the Diary, Notes or Calendar, can be done 
by either clicking in the bottom outer corners of the pages or by using the Page Up / 
Page Down keys. The Today button will open the diary at the current date, and the 
Home key does the same. The buttons to the right of the Today button move the diary 
display forward by one month and one year - Those to the left move the display back 
in the same manner.  

The week numbers shown at the top of the diary pages can be set to ISO (Europe) or 
US standard. In certain years there will be a one week difference in these two 
standards. This is set from the Options menu. 
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When you move the pointer over the diary pages it will change shape according to the 
underlying function.  

1. If the pointer is an arrow, clicking will open a window to allow you to add a new 
entry for that day, unless it is over the pink notepad icon to the right of an entry, 
when it will open the note relevant to that entry. 

2. If the pointer is a hand with pointing finger, the cursor will be over one of the page 
turn curls and clicking the mouse will turn the page.   

3. If the pointer is a square black 'text page' symbol then left-clicking will open the 
edit window to allow you to alter an entry or read it all if it is a multi-line 
entry.  Right-clicking will open a calendar to copy the entry to another day. 

4. If the pointer is a black 'balloon' symbol, clicking will open either the Anniversaries 
list with the generator of the entry highlighted in red, or the relevant entry in the 
Contacts section if the entry was generated by a birthday which has its 'show in diary' 
option ticked. 

5. If the pointer is a letter 'J', clicking will open the journal entry for that day if there 
is one, or generate one for that day if one doesn't exist. If you have set a journal 
password however, it will first open the password window.  

6. If the pointer is a heart shape, clicking will open the Special Day list with the 
generator of the entry highlighted in red. 

7. If the pointer is   (towards the central page ‘fold’), then holding down the mouse 
button will open a graphical display of the whole day showing busy times. 

8. if the pointer is a pair of arrows  then it will also be covering the vertical bar that 
indicates a multi-day event. Left-clicking will move the bar to the left and right-
clicking will move the bar to the right. This is to prevent or cure multi-day bars from 
overlapping.     

  

 

OPTIONS 

The Options window sets your personal choices about how you want In My Diary to 
operate. 

Default files and folders  

The Default diary file box shows the file that will be loaded if you double click the 
program icon to run rather than a file icon. If you are using the standard version then 
this will show the FULL path to the file. If you are using the standalone version then it 
will only show the file name (because your default file should be in the self-contained 
folder that you chose and set up with the program). 
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The Remote backups field is where you set your backup folder (somewhere like a 
network disc drive, Dropbox or other remote destination). Either type in the full path 
to the required folder or drag it to this text field.     

Chosen Journal folder will either show ‘Use Default folder’ or if you drag a folder 
named Journal to this field then its full path will be shown here, and your journal 
activities will use this folder instead of the default one. You can’t write in this field, the 
folder must be dragged here (to ensure it really exists). If you want to revert back to 
the default journal (in your Documents – In My Diary folder) then click the cross icon 
to the right of the field. 

 Chosen Password Manager folder will either show ‘Use Default folder’ or if you 
drag a folder named pw to this field then its full path will be shown here, and your 
Password Manager activities will use this folder instead of the default one. You can’t 
write in this field, the folder must be dragged here (to ensure it really exists). If you 
want to revert back to the default Password Manager (in your Documents – In My 
Diary folder) then click the cross icon to the right of the field. 

You might find this option to choose your own Journal and Password Manager is more 
useful when you want to use the same data with different installations of In My Diary. 
For example: 

1. Where you have multiple operating systems on your computer and want to use 
the same data on all systems 

2. If you want to share the same data with other users who log on to the same 
computer with their own account 

3. If you use multiple copies of the self-contained edition. Normally the benefit of 
the self-contained edition is that everything you need is in a single folder that 
can easily be moved around. But with multiple copies, each copy would 
normally access its own Journal and Password Manager and upkeep of these 
would be tedious. By choosing an external Journal and Password Manager, the 
same data can then be accessed from each self-contained copy of In My Diary.   

 

Font choices  let you set the fonts used for display in the diary and for printing 

address labels. You can choose a different font for the display of diary entries to that 
of anniversaries, and three choices of style when printing labels. The defaults are 
pretty basic and standard and I am sure you will be able to make better choices. Click 
over the font name to open the full font menu.  

Setting the size and boundary of diary event fonts -  When setting a style for 

events and anniversaries, if you notice that the top or bottom of the text seem to be 
clipped you will need to reduce the font size a little or increase the boundary setting to 
give more space for the text. If, in the case of multi-line diary events or repeating 
events, you can see a 'ghost' of the second line or reference number you need to 
make the font size a little bigger, or reduce the boundary setting to ensure that no 
more than one line of text is visible. 

Setting the default colour for diary events – can be done from the Events tab of 

FONT CHOICES. Click over the Default EVENT Text Colour field and choose from the 
colour picker that opens.   
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The Date font setting affects all the date related text in the main diary display (not 
the Calendar) and its size can be fine tuned with the slider control. Date font size is 
dynamic, affected by the size of the diary.  

The Notes font setting allows the default font, colour and text size to be set for 
displaying text in the Notes section. However, individual notes can be given a personal 
text style overriding the default by right-clicking over the text of a particular note.  

 

Alarm sound  allows you to set a sound of your choice to play when event and 

anniversary alarms pop up. You can either choose from the 14 preinstalled sounds in 
the menu or drag a sound file of your choice to the field below the menu. If you try to 
import an inappropriate sound file (or a file that is not a sound file at all) it will be 
rejected and the default sounds will be used instead.  

If you are using the self-contained version of the program and intend to move your 
diary to other computers, please remember that any user-imported sounds must be 
from (and remain in) the IMDiary(L/M) folder when you move to another system 
otherwise the sound will not be found. 

 

Encrypt diary data  - If ticked, your data will be saved in encrypted form. If you 

include a personal key (which is optional) the encryption will also be based in part on 
your key. The only characters allowed in the key are Ascii 32 to 126 (ones you can 
type on a UK keyboard) so you can’t use words containing international letters.  

Open diary as: - Select the number of days you want to see at once (2, 7 or 14). 

Normally when looking at an event in the diary you will only see the first line of the 
text but you can hover over the entry to see the whole text. If you select Two days 
and tick the multi-line box the whole text of an entry will be visible (or as much as 
can be fitted on the page).  

There is also another possible diary view (the running agenda of only events) but it is 
not possible to set this as a start up option. It is selected from the top menu from the 

 icon. In this view you should click once over an event to see the whole text, or 
double-click to open it in the event editor.    

No warning (alarm) messages  - if selected, there will be no pop up messages 

when an event or anniversary occurs (including early warning messages). Email 
notifications will still work if set.  

Audible beep with warning windows   - if selected will produce a pre-selected 

sound when an alarm window pops up. The sound will continue every two seconds 
until the window is acknowledged or closes after the default time. 

Auto save  - If ticked, will save your data when a change has been made and 

therefore you will always have the most recent version saved. 
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Always ask for Password Manager password  - This is the default setting 

when the program is first run or if the Options file is tampered with, but this allows 
you to setup so that the password is only required the FIRST time you enter the 
Password Manager in any diary session. For obvious reasons, this option is only 
available when you are in the Password Manager section. 

Start up with the diary minimized  - Particularly useful if you have the program 

set to run when the computer starts up. The program will then check to see if there 
are any warnings to issue and then minimize to the task bar. On Windows this will be 
the right-hand task bar so the program is running in the background. To open it again 
click over the small icon, or click the show hidden icons button (if needed) to see this 
small icon.  

Use 24 hour clock  - You have the choice of whether to use the 24 hour system or 

the am/pm system of display. This will affect not only the display in the diary but also 
how you input time when adding new entries. 

Hovering shows full event details  - In My Diary events can contain as many 

lines of text as you require, but you will only ever see the first few words on a diary 
page. If this option is set, as you pass over an event in the diary, pausing for a 
moment over an entry will open up a window which shows the entire text (or as much 
as can be seen sensibly, but you can scroll through the rest). 

Early warning default, Show time default and Overla p warning 
default  - If these are selected then their relevant tick boxes in the Set Alarm window 

will be checked when you open the window to add a new entry to the diary. 

Check for program updates  - If ticked, the program (as it loads) will check over 

the internet to see if there is a more recent version available. If you are using the 
program regularly on a non-internet based computer you might want to deselect this 
as it does make a very small difference to the start up time of the program. Holding 
down the shift and Ctrl keys as you load the program will bypass this check but will 
also deselect this option. 

Default window startup size . In theory, the diary should open at the size it was 

when you last saved it, but it took a while before I got rid of some troublesome bugs 
which caused the diary to open sometimes as a very small window. This should no 
longer be an issue on any system but, if you do experience this problem, ticking this 
box will make sure that the diary always opens at the default size. This option may be 
depreciated soon. 

Calendar Page turn  - When the calendar tab is open, page turns will increase or 

decrease the visible calendar by either 6 or 12 months. 

Week numbering  - There are slightly different standards about when week one is 

in a new year. Depending which country you live in, you can opt to select the 
appropriate one for your area. 

Set time zone  – This allows you to synch the program with the time zone of your 

local area. Its chief purpose is to make sure that any iCalendar data read or written by 
In My Diary will send or display the correct REAL or absolute time. If you choose to 
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set this manually, click in the time field and select the correct time zone from the 
examples there. All currently used time zones are selectable, but there is only one 
locality example for each zone. 

If you select Computer (auto) then the time zone will be based on the global 
settings in your computer.  

If the export UTC Time box is ticked (the default), exported events will have their 
display time affected by the time zone setting so that events are scheduled to occur at 
Universal Time which may or may not be the same as that where the diary data 
originated. If it is not ticked, the time written in the diary will be used to stamp the 
event time (more details). 

Move/copy events  - Dragging an event from one place to another in the diary will 

either copy or move that event (or ask you what you want to do). Select your default 
option here but you can also change this default by doing Ctrl-C (for Always copy) or 
Ctrl-M (Always move) whenever the diary is open.  

Enable dialling icons  - If you still have an analogue modem in your PC (or as a 

peripheral) connected to a phone line then you will be able to dial numbers in the 
contacts section through the modem.       

  

 

CONTACTS 

Click the  icon at the diary top to open the address book. When you select the Add 
new contact button a blank record is created. Providing you add at least a surname, 
you can then select Keep or Cancel to confirm or reject the new entry. The Early 
warning tick box and field sets the number of days prior warning given of their 
birthday.  

Contacts can be assigned to categories (such as Work, Friends etc) for the purpose of 
printing labels etc. Initially there are four default categories (Work, Friends, Home, 
Christmas Cards) but these can be renamed and others added up to a maximum of 12. 
Each contact can 'join' as many categories as is appropriate.  

To add or edit category names, select the 'Add category' button from the Contacts 
window. To add a new category (providing you have no more that 11 already) just 
click on the line below the last entry and type in the new name. 

To assign a contact to a category, select the 'Join/leave' button from the Contacts 
window and click over the category name so it becomes ticked. Clicking a ticked row 
will remove the category from that contact.  

You can include a link to a photo or other image file by dragging an image file to the 

‘face’ icon.   When there is a photo assigned a green border surrounds the icon. 
Click the icon to open the photo. To unlink the photo right-click over the icon. To 
change the linked image just drag a new image file to the face icon.   
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The full date format for the date of birth field is dd/mm/yyyy but you can enter a 
single digit day, month and even year. The delimiter between these can be - / or 
space so entering 1-2-1 would resolve as 01-02-2001. If you enter a two digit year, a 
number greater than 25 will default to the 20th century - one less than 26 will default 
to 21st. To enter a year such as 1910 you would have to enter the year in yyyy 
format or use the adjoining calendar. 

To enter a birthday when you don't know the year (or you don't want their age to 
display in the diary) enter a '0' for the year or tick the 'Don't show year' option if 
using the calendar.    

 

Adding contacts from other programs 

If you have previously used another personal organizer you should, in nearly all cases, 
be able to transfer your contact details from your old organizer to In My Diary. This is 
done by means of either creating in your old organizer a vCard file, or a CSV file and 
dropping that onto In My Diary. If you have the chance and your contact list is 
straightforward, a vCard file is the simpler way to do this because you don’t have to 
do any work in deciding which fields (such as Address:Street, Address:Town) in your 
old contacts match up to the fields in In My Diary.   

However, not all organizers give the option of exporting vCard files, or you might have 
special requirements – for example you might have multiple addresses for each 
contact. In My Diary will always look to import the HOME address for each contact in a 
vCard and you might want to import an alternative one. In this case, you would need 
to use CSV import. Either go to File > Import > CSV contacts and choose your CSV 
file, or just drag it to the main diary window in In My Diary. 

This will open up a window listing, on the left side, all the possible contact fields in In 
My Diary and, on the right, all the fields that have been found in the file you are 
importing. All organizer programs export different amounts of contact information for 
each person, and in a different order, and you will then need to reassign the rows on 
the right to the In My Diary fields on the left. In My Diary has 17 fields of information 
but some programs have more than 100 – You need to pick the ones you need to 
import. You do this by clicking the mouse over a field on the right that is in the wrong 
place (for example, First Name might be level with Address1) and dragging it up or 
down until it is level with the correct label on the left side. You can import three extra 
fields from your old program (line them up with ‘Add this row to Notes’) and these will 
be added to the Notes field in In My Diary so that you can decide what to do with 
them later.   

Once you have your fields in the order you want them you can save a preset from the 
top left of the screen. Just click over the ‘choose preset’ field and select ‘Add preset’. 
This is useful for if you import your contacts and find you have got something in the 
wrong order, or if you want to add more contacts at a later date from the same type 
of CSV file.  

CSV import definitely involves more work that vCard, but it does also offer more 
flexibility. It comes down in the end to personal choice or necessity.     
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Printing address labels 

You can either print address labels directly from In My Diary (14 per sheet – 99 x 
38mm) or create a CSV file for use with 3rd party label printing software such as Avery 
Design & Print when you need a different label size. To print labels select File > Print 
Address labels from the Contacts page, choose From ‘InMyDiary’ or ‘Export csv’ and 
then either select 'All ticked contacts' or 'From selected categories'. The first option 
will print any contact that has the 'Select for printing labels' checkbox ticked. The 
second will print contacts that have been selected from the window that first opens. 
Close the window once you have made your selection. 

If you are printing directly from In My Diary you can also set the label you wish to 
start from and also choose from three types of font style (the actual fonts can be 
selected in the Options > General Options window in FONT CHOICES - Labels). 

The All button allows you to set or clear all ticks. If you enter a name into the Label 
name box this will be printed instead of the First Names and Surname entry. So you 
might have two individual entries for friends who are partners, but only want to print 
one label to send a joint Christmas card. Therefore, just tick the box for one of the 
couple. 

  

THE CALENDAR  

Click the Calendar tab to open the 12 month calendar. Two-page increments can be 
12 months or 6 months set from the Options menu. Click any date to be taken to that 
day in the diary.   

Click over the year at the top of the left-hand page to select the year you require.  

Creating a new event using the calendar  

If you select a date using the left-hand mouse button the diary will open at the 
selected date. If you select a date using the right-hand button the Set Alarm window 
will open so you can make a new diary entry for that date.  

  

ADDING EVENTS 

With the diary section open, click anywhere within the day required (providing the 
pointer looks like an arrow) and the Set Alarm window will open for you to add events. 
(If you already have 3 or 4 events in that day, make sure the pointer is an arrow - try 
clicking just above the lower day divide line.) You can also select a date from the 
Calendar section by right-clicking over it and this will also open the Set Alarm window. 
Your event data can be as many lines long as you require, but only the first line will 
be visible on the diary page (unless you have the two-day view set and have allowed 
multi-line display in Option). If you have set more events in one day than can be 
displayed in the space available, a small triangle will appear near the page margin and 
you can click this to scroll to other events.  
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If you need to change the day of the event from the one over which you clicked, there 
is a calendar icon to the left of the date and this allows an alternative date to be set.  

Times can be inputted using 24 hour clock or am/pm. This is set from the options 
window. If am/pm is selected the am or pm suffix will appear alongside the time, and 
you can click this text to change to the alternative one. If you include a start AND 
finish time for an event on a particular day, if any other events fall within that time 
period a warning message will appear the first time that day is 'seen' by In My Diary, 
or if either of the events are edited during a diary session. The All day tick box blanks 
out the time boxes and entries in the diary will have an (all day) prefix before them 
whether or not you have chosen to display the time in the diary. 

Entries can be given differing text colours by clicking over the Text colour button and 
choosing from the colour chart. If you have set a category for the event (see below) 
then the colour you choose will apply only to that category. 

Once you have made an entry, you can see the whole data again by clicking over the 
entry and the Edit Alarm window will open. This also lets you make changes to an 
entry. You can also see the whole data by hovering the mouse over an entry and after 
a moment a window will open displaying the full text. You can't edit an entry this way 
however.  

If you tick the early warning box, you will get a message as you load the diary if the 
event is within the number of days shown.  

How events extending to other days are added and sh own in the 
diary 

If the event covers more than a single day you can add additional days under the End 
time boxes (either type in the number of additional days or use the increment 
arrows). Once you confirm the event with the OK button, a coloured bar will appear on 
the left side of the day display to show which days are part of the event, and a rough 
graphical guide to the time of day when the event begins and ends.  The bar has a 
random colour and you can change it by holding down the Alt key and clicking 
anywhere along its length until a suitable colour appears. If you left-click the bar it will 
move 10 pixels to the right (right-clicking moves 10 pixels to the left) so that you can 
arrange overlapping bars more neatly if necessary. If you position the mouse 
anywhere over a coloured bar without clicking it for more than one second an 
information window will open containing a few words from the description of the multi-
day event; this helps you identify which events are associated with which bars, 
especially when they stretch over many days or when there are several overlapping 
multi-day events together.   

Owing to some restrictions within the initial program development, repeating multi-
day events will only show the coloured bar for NEXT due repeat.        

 

Assigning a Category to an event 

The purpose of this recent addition (version 3.01) is currently to enable more refined 
searches of the diary, but categories may be used in other ways in future editions. 
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Click over the (No Category) field. Initially, there will be just a few default categories 
to choose from, but you can create others by selecting Add categories from the 
menu. This will allow your input into the category field, and providing you create a 
new event (or complete the editing of an existing one), and providing the category 
name does not already exist, a new one will be created and added to the menu. 

Once you have set or created a category, using the colour picker to the left of the 
category field will only apply to that category and if you change the text colour all 
entries assigned to that category will change colour in the diary. 

You can change the name of existing categories by selecting Edit category name, 
and this will allow your input into the category field.     

If you select Delete Category, that category will be removed and ALL EVENTS 
ASSOCIATED WITH IT WILL HAVE THEIR CATEGORIES REMOVED. 

 

Repeating Events  

Repeating events can be set, based on every 'n' days/weeks/months or years, every 
1st/2nd/3rd/4th or last particular weekday every month, or the Last day of every 
month. When you first open the Set Alarm or Edit Alarm window the repeat settings 
are hidden. To show them, tick the Repeating events box. Set the type of repeat 
required. The Last day of each month option will only be available if you have 
actually started the process by clicking over the last day of a month. Similarly, the 
third option (on the ???? each month) will be pre-filled with the week and day 
correct for the day you clicked. If the 4th week is current and displayed, you will be 
able to click over the 4th box to change it to Last. This will then repeat, for example, 
on the last Wednesday of the month rather than the 4th Wednesday (which may or 
may not be the same thing). 

  

You can omit dates when you don't want the event to repeat by clicking over any 
repeat of an event you have set. If the Delete this repeat button is displayed (at the 
bottom of the window), then clicking this will remove the repeat on the day selected. 
You can reinstate the repeat by clicking over any other repeat of the same event and 
editing the dates to omit from the except on: list. You can also add dates to this list 
but be careful to use the format dd/mm/yyyy. It is not possible to delete the next 
occurrence of an event since this is the one from which all other repeats are devised. 
If you need to delete such an occurrence, then you should instead move it to the date 
when the next repeat should occur. Please note that if you move or copy a repeating 
event to another date the list of omitted dates will not be copied to the new date, 
since these would probably be inappropriate anyway.    

If you know when the repeat should stop, add it in the until: field either using the 
calendar at the side or type the date (format is described in the contacts section). If 
you do not set a finish date the event will appear in your diary for 70 years which is 
probably good enough for most purposes!! The tick box if moved or copied keep 
the finish date relative to the new start date is useful if you want to copy or 
move a repeating event to another date. This way the length of the repeating period 
is preserved rather than the actual original finish date, so it is easy to set blocks of 
events that repeat for the same length of time by copying the first one to different 
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parts of the diary. The need for this will become obvious if you don't get the result you 
expect.  

 

 

 Adding 'computer task' events  

This facility allows In My Diary to open and run a program or file on your computer at 
a given time and/or date. You can also launch a URL (open a website, ftp client or an 
email) with this facility.  

This is the same procedure as adding a normal event (as above), but instead of 
writing a real event into the event text box you should drag the icon of the file or 
program to be opened to this box (or type its full pathname or URL if you know it). 
You can also usually drag a URL from a web browser into the event text box. Dragging 
files or URLs to the box will delete any text already there but, once dragged, you can 
add other text on new lines above or below the ‘active’ line if you wish. So, for 
example, instead of the diary displaying a meaningless URL such as 
https://www.google.co.uk/maps/place/Marylebone,+London+W1A+1AA/@51.5185614,-
0.1437991,17z/data=!3m1!4b1!4m2!3m1!1s0x48761ad44b20e957:0xd990c323a691577b you could put that 
on the second line and have ‘show BBC map’ as the first line and therefore displayed 
in the diary. 

Tick the 'Computer task' checkbox to confirm this entry as a task and you can then 
click the Test button if you wish to check that the file will open as desired. 

At the set time the file or program will run or the URL will be launched. The whole text 
of the entry is searched first for a line starting with a path to a file or program. If one 
is found it is launched. If one is not found the whole text is then searched for a line 
starting with a URL. If one is found it is launched. This allows the visible text in the 
diary to be a more useful heading etc. rather than the actual link. 

Once you tick the 'computer task' checkbox the early warning, early email and email 
warning options become unavailable since they are not relevant to this function. You 
can however set repeating task alarms as usual based on every 'n' days or every 'n' 
months.  

If you open a task alarm in the Edit Alarm window the 'computer task' checkbox is not 
present but in its place is a message that 'This is a computer task'. 

 

USING THE TO DO LIST 

Clicking the To Do tab opens a list where you can add tasks that you need to attend to. 

Unlike the Notes section, To Do tasks are listed on a single scrolling page, but you can 
select the status to see all tasks or a sub-set.  

To Do tasks can be open-ended with no fixed start or end date, or they can have a 
specific start date and a due-by date. While ever tasks are on-going, they will appear 
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on the current date in your daily diary, slightly smaller that the default event text and 
also inset a little. A red entry means that the task has passed its due-by date, a green 
entry means that the task is still within its agreed completion period. Tasks due to 
start on a future date are shown in blue on the appropriate date, and tasks that are 
completed are shown in black on the completion date.   

To create a To Do task, click the Add icon at the head of the list. You can then set the 
task name and its running period. If you want a pop-up reminder when a task is 
overdue you can tick the checkbox to select this. Pop-up reminders will occur when 
you first run In My Diary on a particular day, or at the start of a new day if you run 
your computer 24/7. If you do not dismiss the pop-up during the 15 seconds it 
appears on screen, it will reoccur each hour. Once dismissed, the reminder will not 
appear again that day. 

Providing you have given the task a start and due-by date you will be able to click the 
Repeat button where there you can choose from a comprehensive set of repeat 
options, and set a date when the task will stop repeating. 

To edit task details or mark as completed, click over the task name in the list. 
Repeating tasks can be opened for editing but the repeat frequency and stop 
repeating date are visible when you click the Repeat button, but not changeable.    

To Do tasks are also imported when you import an iCal file if any are included in the 
file. Not all possible types of data are imported and you can see what is actually read 
in Appendix 1      

   

HIGHLIGHTING SELECTED DATES  

If you want to highlight particular dates in the dairy (whether or not they have any 
associated events) you can do this by shading the background for the required days. 
You might want to do this to see easily days when you are away on holiday or at a 
conference without having to write this as an entry for every day affected (Great 
morale booster for teachers to see at a glance the school holidays approaching!).  

Firstly you need to define the colour shade, and you can set up to 10 different shades 
for 10 different highlighting purposes. The colour white is assumed to be the non-
highlighted colour so this cannot be selected as a shade. In reality, the real colour of a 
'normal' diary display varies on different OS, but the system needs to have a colour 
assumed to be 'no shade' and white has been selected for that purpose.  There is a 
colour (light blue) already defined and set as default if you are using this function for 
the first time, but you can overwrite this colour and set others by going to the 

Options > Set background highlights. Here you can give your highlight a 
description (such as holiday) and set the colour by clicking the colour rectangle. 
Obviously, in order to see the date and entries for the day, it is a good idea not to use 
'heavy' colours as backgrounds so you will probably need to define custom colours 
when the colour picker opens. 

Once you have defined your highlight palette, to give a date a shaded background 
select the desired active colour either by right-clicking over blank space within any 

day (which opens the Select Shade window), or from the Options > Select active 
background highlight menu. You can highlight other days with the currently 
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selected colour by holding down the Ctrl key (+shift key OSX) and left-clicking in the 
day you want to highlight. To remove a highlight, again hold down the Ctrl key (+shift 
key OSX) and left-click in the day, or select the 'Remove highlight' icon if you are in 
the Select Shade window. 

EMAIL NOTIFICATION 

In My Diary can be set to send you (and others on a Bcc list if desired) early warning 
and/or arrival time notification of events in your diary. When you set or edit an event 
you can choose whether to receive an email at event time and/or 1 day before. Just 
tick the appropriate checkbox when setting or editing an entry. 

Before this will work, there is some straightforward setting up to do from the Options 
window. In this window click the Email alert setup button.   

By default the system will use In My Diary's own web server to send the emails and to 
use this all you need to add is your own email address. You will also need to register 
this same email address at www.inmydiary.co.uk/register.php. which also enables you 
to receive information about updates. 

Ideally (and for greater reliability) you should use your own email provider's server, in 
which case you will also need to give the SMTP server address of your email provider 
and may need to change the Port number if 25 (the default) doesn't work. If you have 
set up an email client such as Outlook or Thunderbird you will probably already be 
familiar with adding this, but you can find out the address from your provider's 
website. It is usually something like mail.myprovider.com or 
smtpmail.myisp.com.  The Username and Password for authenticated SMTP are only 
normally needed if you are using In My Diary on a computer away from your home, 
where the Service Provider will probably be different from your home setup. Currently 
SSL (secure) connection is not provided so you might have a problem if you use an 
email provider that always requires authentication and secure connection (Gmail, 
Yahoo etc.). If this is the case, use the In My Diary server but be aware that traffic 
(not content) using this means will be monitored as described here: 

1. The availability of the In My Diary server will be subject to review, based on total 
traffic and the frequency of messages sent by individuals. 

2. The actual body of genuine messages from a registered address will never be read 
but if it is felt that an individual is overusing the system by generating many event 
messages and sending them to lots of Bcc recipients (which might indicate spamming 
action) their address will be added to a blocked list and this will prevent further emails 
from being sent, although attempts are logged. The body of a message will be read 
if the email address used is improperly formatted or the address has been added to 
the blocked list.  

3. If In My Diary's hosting service is not happy with the total amount of HTML emails 
being generated, you will receive notice of this (from the program, not as an email) at 
the time the event would normally send an email and I will also post this news to all 
registered subscribers.  

To Bcc someone else with the event notification email, the person(s) must be in your 
Contacts and, obviously, their email address must also be there. Then when you click 
on the Bcc email addresses button (when adding or editing an entry) their name 

http://www.inmydiary.co.uk/register.php
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and email address will be included in the list that opens up. Click over the name or the 
checkbox to add or remove a contact from the Bcc list.           

You can use the test button on the email setup page to make sure the setup you are 
using actually works. This will send you a confirmation email if everything is ok, or 
you will get an appropriate error message if the settings you are using do not work. If 
you do not appear to be receiving email notifications, you can check the Email error 
log from the View menu which will show you the history of any failures to send. Also 
remember that, if you are using the In My Diary server option, you must be registered 
on the In My Diary website. If you are not, the system will not work and you will 
receive an email advising you about this. 

  

MOVING AND COPYING EVENTS TO ANOTHER DAY 

You can move and copy events to other dates very easily within In My Diary.  

If you simply want to move an event then click over the event so the event editor 
opens. To the left of the event date there is a little calendar icon and clicking this 
allows you to move the event to an alternative date. 

If you want to move the event to a date that is currently visible then this next method 
is even quicker. Copying an event rather than moving it can also be done in the 
following way:  

Firstly, from the General Options menu you should set the default action for 
'move/copy events'. This can be Always move, Always copy or Always ask the user. 
Then to make a copy of or move an existing event to another day: 

1. Hold down the left mouse button over the event 

2. Drag the pointer to clear space on the date you want to move to 

3. Release the mouse button. 

If the day you want to move/copy to is in a different week: 

(please note - this function does not work in the native Linux version) 

1. Right-click over the event you want to copy or move 

2. Select 'Copy event to clipboard' from the menu 

3. Turn to the required page using the page corners or the Page Up/Page Down keys 
(not the calendar)   

4. Right-click over the day required and the event will be added to that day. 

When an event is copied to the clipboard, if you do not proceed with 4 (above) but go 
on to perform some other function the copied item will be removed from the clipboard. 
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Alternatively if the date to move to is far off (or you are a native Linux user), right-
click the mouse over the event to copy and select 'Open copy event calendar', then 
select the required date from the calendar.  

Once copied, these events can be edited independently of the original one (unlike 
repeating events, where only the original entry can be edited or deleted).  

If you are copying an event that repeats, you might want to tick the if moved or 
copied keep the finish date relative to the new start date box (click the event to 
edit it to see this option). This will preserve the length of time for which the event 
repeats rather than the original finishing date. Otherwise you might find you are 
copying the event to a date which is already past the original finishing date (so no 
repeat would take place). It depends why you need to do the copy or move in the first 
place and I am sure the need will become obvious if you don't get the result you 
expected. 

 

SEARCHING THE DIARY, NOTES AND CONTACTS  

Either click the ‘magnifying glass’ icon from the icon bar or from the Edit menu select 
Find or do Ctrl+F to open the Search window. 

You can perform searches of Events in the Diary, Note names and Note contents, and 
all fields from Contacts except Label name. The tick boxes allow you to confine your 
search to just one, two or all three sections. The date range allows you to refine your 
search criteria further, and by default it will be set between the first event in the diary 
to the end of the current year. 

With Use Search field displayed in the menu, you can type any numbers or 
characters in the Search field, press the enter key or click the Search button and the 
results will be listed in the main window. 

If you have set some categories to classify your events, you can refine the search 
further by clicking over the field that initially says All Category, select a category, and 
that will allow the search to be restricted to events given that category only. 

Searching dates for Saints days (such as Easter), b ank holidays etc. 
in other years 

The other type of search you can do is to list the dates of any of the Special Days you 
have assigned that vary each year or are Easter related. Set the year range you are 
interested in and select the Special Day from the menu that initially says Use Search 
field. 

 

 CHECKING ‘TIME BUSY’ WITH A GRAPHICAL DISPLAY 

It has always been my intention to keep the initial appearance of entries in the diary 
as uncluttered as possible, and to maintain the traditional ‘written’ diary look. 
However, I am also aware that users can benefit much from seeing a graphical 
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representation of busy times and free times during a day and so, from version 3.10, it 
is possible to do this by positioning the mouse pointer towards the centre page ‘fold’ 

so that the mouse pointer becomes    If you then click and hold a mouse button the 
events of the day are laid out graphically. The start and end times are shown with a 
horizontal line with the first few characters of the event accompanying the line. Events 
that have the same start and finish time are given a nominal 10 minute line to make it 
easier to see the entry. Events that stretch over more than one day have appropriate 
lines through the whole or part of a day as required.  

Adjusting the time and number of days of an event u sing the slider 
control 

If you click over the time line of an event in the busy time window just mentioned, a 
time adjust window will open and the slider control allows you to adjust the start and 
finish times of the event. Click and drag over the end of the slider to change either the 
start time (left side) or finish time (right side). Clicking in the middle of the slider 
DOES NOT move the start and finish times together as you might expect. 

If you drag the slider to the right beyond midnight then the event will run into a new 
day and the window will change to allow precise setting of the end time or to add 
further days.  

Similarly, you can decrease the number of days in an event by dragging the slider to 
the left beyond midnight. 

If you can see the ‘faded’ extensions to the right and/or left of the main 24 hour time 
scale, clicking over an extension will show the time line for the previous or next day of 
the event.  

Please note that you can’t drag the start time of an event backwards to the previous 
day or forwards into the next day. If you try to do this the start time will be set two 
minutes before or after midnight (depending on the direction of the drag).  

When the slider is very short (when just before midnight or if an event is just a few 
minutes long) you need to click just to the side of the slider to change it. Normally 
clicking to the side will not have any effect – This just works when the slider is too 
short to click over.   

 

NOTES   

The Notes section is accessed by the Notes tab at the side of the diary pages. Initially 
there will be an INDEX on the left-hand page and a blank space on the right-hand 
page. First, create a note by right-clicking within the INDEX area and selecting Add 
Note. Notes can either be general text or a financial list of transactions. 

Once you have given the note a name, it will appear at the top of the right-hand page 
and you can then type the text of the note, or paste it in from elsewhere. 

If you have created more than one note it will be possible to turn to other pages using 
the page curl icons at the bottom of the pages, or the page up/down keys.   
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General Text Notes 

You can type and paste from other sources anything text-based in this format. You 
cannot drag images (or other media) to Notes. If this is your intention then a journal 
entry using the ‘Word’ setting might be a better option. 

 

Financial list Notes 

You can think of each note as an individual bank account.   

The first time you create a financial list it will also create a master Totals list of all 
your financial list pages of which there can be as many of these (like separate 
accounts) as you wish. 

To add an entry to a financial list either select the Add new entry button at the foot 
of the list or right-click and select from the menu. 

Although not seen in the list display (to save space), entries are date-stamped and 
can also be given a category. Once created, double-click an entry to edit its details. 
You can also mark an entry as reconciled with your bank account statement this way 
(or by right-clicking and selecting from the menu or pressing the R key over an entry). 

Transfers can be made (based on the usual selection of individual or repeating entries) 
either between financial lists you have created, or can be ‘paid from’ or ‘paid to’ an 
external account. This allows the effect of standing orders and direct debits on your 
accounts to be recorded.        

Data can be imported into financial lists by right-clicking over the required page, and 
selecting import. At present only QIF files can be imported owing to their not requiring 
field mapping, but other types may be introduced later, and there are online or 
standalone apps which will convert CSV etc, to QIF format.  

Financial Notes can be searched and searches refined further by either right-clicking 
over the Note and selecting Search or by pressing the S key over an entry. Once a 
search has been performed you can then export the data to Excel (or similar). To 
export a whole original financial note just do a search with the details field left blank.  

The results of a search can still be refined further if needed. 

The text design (font, font colour and size) of your Notes can be set in the Options 
Window, but individual notes can also be given a personal text design by right-clicking 
over the main body of a note.  

 

ADDING A NOTE TO AN EVENT  

To add a note to a diary entry when creating or editing an event, either select an 
existing note from the menu (click the notepad icon) or click in the note link field to 
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create a new note name (if you type a note name that already exists the event will be 
associated with that note).  

If you click on the Notes tab at the side of the diary this will open the Notes index and 
your new note name will be listed there. Click over the note name in the index to open 
its page. You can also directly open the note page for that event by clicking on the 
small notepad icon at the right of the diary entry.  

When looking at any note page, clicking its name at the top of the page will open a 
search window showing all the entries in the diary that are linked to that particular 
note.  

 

ADDING A FILE OR A WEBPAGE TO AN EVENT  

To add a link to a file or webpage when creating or editing an event, either drag the 
file (or the web address from your browser’s URL bar) to the note link field, or type a 
web address (beginning with either http, https or www). Please note that you cannot 
type a file path (for example, C:\Users\Public\Documents\myfile), files MUST be 
dragged to the note link field. If you use Windows 10 and want to link an image file 
to your entry, you may need to drag it to the small ‘face’ icon to the left of the note 
link field rather than the field itself. Windows 10 tends to try to display images 
dragged into InMyDiary rather than recognise their path.    

The Note link field can be used to associate files or notes to an event. These can be 
either a note in the Notes section of InMyDiary, a file anywhere on your computer, or 
a web address. It is not possible to link more than one of these three types to a single 
event.  

When a link is present, a small icon will appear in the diary to the right of the event 

entry. A note is shown by a notepad icon , a file is shown by a paperclip icon  

and a web link is shown by an ‘earth’ icon . Clicking the icon opens the Notes 
section at the relevant page or opens the file or the webpage. 
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MEMORY-AID CLOCK 

This facility is an alternative front-end display, still using the diary as a data source 
but with a full-screen clock with large display help messages intended to help those 
with memory related illnesses or the elderly who appreciate the on-screen 
reassurance throughout the day. For example: 

 

 

One special message per day can be created (above would have been entered as 
“David and Joan’s for lunch”) which is intended to be the user’s main activity that day. 
Throughout the day the message alters slightly depending on whether the time is 
before, during or after the event. In addition, pop-up messages can be set for specific 
times which are announced by an audible alarm for a user-set number of seconds, and 
which then stay on screen for a user-set number of minutes. 

If the computer running the clock has internet access then it is even possible to send 
continuous message updates to the clock from a remote computer, tablet or phone. 
For more information see the dedicated help file. 

 

PASSWORD MANAGER  

From version 2.00 you can now store and generate passwords for email, FTP, online 
passwords etc.  

Click the Passwords tab to access this. If this is the first time you have done this you 
will first be asked to generate a login password. Unlike the overall In My Diary 
password and journal password this is NOT optional - maybe you're not to be worried 
if another family member accesses your diary or journal, but NO ONE should ever 
have access to your password data, so the necessity to set a login for this is not an 
option. By default you will be asked for this password every time you access the 
Password Manager, but you can change this setting from the General Options menu so 
that you only need to give the password once after opening a diary file. You need to 
be inside the Password Manager section to do this. 

http://inmydiary.co.uk/MAC_help.pdf
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Passwords can be made from all UTF-8 characters so international words are possible 
(from version 3.12) and is triple encrypted before storing as part of your password 
data file. This password also forms part of the blowfish key that encrypts the entire 
password database. This ensures that your password data can only be read by 
someone who has access to your login password, otherwise the data is unreadable. 
Because the password controls the overall encryption, you can only change the 
password (from the Options menu) if you are inside the Password Manager. UNLIKE 
OTHER PASSWORDS USED IN IN MY DIARY, I AM NOT ABLE TO HELP YOU 
RECOVER THE PASSWORD YOU SET FOR ACCESS TO THE PASSWORD 

MANAGER SO YOU MUST REMEMBER IT. 

Password data is stored as separate entries within parent folders (such as 'Banking') - 
The parent folders are shown in the top left-hand section of the Password manager, 
and the multiple entries for each parent folder (showing, for example, separate bank 
accounts) are in the list below. The right-hand page contains the editable data for 
each entry and becomes accessible once a selection is made from the entry list.  

When you first open the Password section there are two 'parent' folders already set for 
you - General and Banking, and one entry, 'New entry', for each parent. 

To create more folders, either right-click somewhere in the top list and select 'Add 
new folder' or access this from the Edit > Password Manager submenu, or click 
anywhere in the top list and press the Insert key. Entries within each parent folder 
can be moved to a different parent folder by right-clicking over the entry and selecting 
Move entry to different folder (or access this from the Edit > Password Manager 
submenu). 

To create more entries in a parent folder, first select the correct parent folder, then 
right-click within the lower list and select Add new entry (or access this from the 
Edit > Password Manager submenu, or press the insert key).  

Folders and entries can be deleted from the same menus. or click in the appropriate 
list and press the delete key. 

Parent folders and new entries can be renamed to suit your purpose. You can also 
give parent folders an associated icon to help categorise it. Right-click over the parent 
folder and select Set Folder icon and select from the window that opens.  

You can either create your own passwords (or copy them from current sources you 
use) or let In My Diary create random passwords for you (with the Make button). If 
you choose the latter, you can set the parameters used by clicking the Options 
button under the password field which lets you select the character types you want 
the password to use, and the length you want the password to be. If you choose to 
create your own passwords, the typing field below the 'Password' field should be used 
to retype the password to double-check the typing. If you retype correctly the field 
will turn green. Typing in the password field also readjusts the default length of 
further passwords created. 

As you type, or after using the Make button, the security of the password will be 
shown in the Strength field. 

You password data is only loaded into memory when you have the Password manager 
open, and is encrypted whilst stored in memory to prevent it being read if you were 
unfortunate enough to have any spy-ware aboard.        
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Effectiveness of passwords 

Testing the strength and effectiveness of passwords has been well documented in 
many websites and there are many opinions as to what constitutes an appropriate 
password. The principle method used in In My Diary is based on password entropy, 
which defines its randomness and the level of difficulty a computer would encounter in 
trying to discover a password by repeated attempts at trying all possibilities. Entropy 
is described in bits, and is worked out logarithmically by calculating the number of 
possible characters in use (only using numbers would be 10, but all ascii printable 
characters is 95) and giving each character in the password an entropy score. This is 
then multiplied by the number of characters in the password to give a total entropy 
score. In My Diary also uses a word dictionary which contains the 500 worst 
passwords so if you happen to select one of these the strength score will plummet. It 
also uses a method of giving bias to different parts of the keyboard - some people 
might produce a password with one hand in one location of the keyboard because it is 
easier to retype. This will generate a lower score but, like familiar words, is not strictly 
reflecting random entropy but is nevertheless important because it includes the 
human decision making choices into the process.  

Some guidance about how strong your passwords should be for specific purposes can 
be found online and I would hesitate to give specific guidance here. The amount of 
green in the background of the strength field might give you encouragement but 
that's all I would say on the matter. One piece of advice I would give is if you do look 
at online password strength testing websites, while these might be good for getting 
opinions about how strong your password should be, please consider the full 
implications of typing your REAL passwords into a place designed to check (and 
identify!) passwords. Many may be purely philanthropic and safe, but how do you 
know? I would like to assure you however that In My Diary does not have any 
mechanism built in to harvest any data you create, be it personal diary data, journal, 
passwords or any thing at all.      

  

Using the passwords you generate 

Randomly generated passwords are difficult to remember or guess (that is, of course, 
the whole point) so you need to be able to use the passwords easily. You can copy a 
password to the global clipboard (so it can be used outside In My Diary) by selecting a 
password entry (from the lower list) and pressing Ctrl+C. You then have 12 seconds 
to press Ctrl+V to paste the password into the document you need. After that time 
the password will be erased from the clipboard as a security measure.  

Sometimes you have to quote a few characters from your password and there is a 
built-in method to make this easy to do. In the Character position finder type the 
positions you have been asked for separated by any non-numeric character - (eg. 
1,3,10 would then show the characters at those places in your password).  You can 
type up to four place finders.     
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ADDING AND EDITING ANNIVERSARIES  

From the Edit menu select Anniversaries or click the balloon icon on the top icon bar. 
You can also open the Anniversaries editor by clicking directly over an anniversary in 
the diary. In this case the event you clicked will appear in red in the list. 

Either click the anniversary you want to edit or select Add New. 

Enter or edit the base date (eg. year of wedding etc.) and any early warning you 
would like of the anniversary. You do not need to include a base year.  

If you include %t in the message then, providing you have included a base year, the 
year since the base date as an ordinal number (1st, 2nd etc.) will be added to replace 
the %t.  

If you add %n (and you have included a base year) then just the year since the base 
date will replace the %n.  

It is not necessary to add either the %t or the %n, but in this case no number of any 
kind will appear in the alarm. 

If you want to copy your anniversary data to an installation of In My Diary on another 
computer you can do this from the File menu > Go to ... > Anniversary file etc. 

This will open the folder where your personal anniversary, special day data (called 
'holidays') and options files are kept. 

  

EDITING 'SPECIAL DAY' DATA  

The diary will display public events and anniversaries associated with particular days if 
you want it to. This is called Special day data and includes days such as Christmas 
Day and Saint’s days which are always on the same date each year (Fixed-date 
event), Bank Holidays and Daylight saving time days etc. whose dates vary from year 
to year (variable-date event) and Easter and other dates related to the date of 
Easter (Easter-related events). Initially, because I am from Britain, the default days 
will revolve around the British calendar but can be edited to make them more 
personal to your needs.  

From the Edit menu select Special days or click the ‘family’ icon on the top icon bar. 
You can also open the Special Days editor by clicking directly over a Special Day 
notification in the diary. In this case the event you clicked will appear in red in the list. 

Either click the Special day you want to edit or select Add New. If you have selected 
Add New you will then need to specify the type of event you are creating from the 
three mentioned earlier. 

The amount of data you will need to give varies depending on the type of event. All 
events need the event name as you want it to display in the diary, but Fixed-Date 
events also need only the month and the day of the month. Variable-date events need 
the day of the week (Monday=1 to Sunday=7) and the earliest and latest possible 
dates in the month that the event can occur. So, for example Remembrance Sunday 
can range from 25th to 31st of the month of November. 
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Easter-related events only need the number of days before or after Easter when they 
should appear and a slider helps you to set this. You probably wouldn’t need to but, 
owing to some necessary processing within In My Diary, it is not possible to set 
another Easter related event that is actually on Easter day. For similar reasons, you 
cannot delete the existing Easter day entry, but you can delete its event name if you 
don’t want it to show.  If you have a different name for Easter then you can change 
the event name to that of your own language. So, in French this would be Pâques.  

Easter day and the first two entries (which are daylight saving related) cannot be 
deleted since they have special responsibilities within the program. However, their 
names can be changed to suit local circumstances. Other entries can be deleted if you 
don’t want them to show in the diary. 

Easter day is the only event which is allowed to have NO event name. 

Close the Special Days window to save your changes and see the effect in your diary. 

If you want to copy your Special day data to an installation of In My Diary on another 
computer you can do this from the File menu > Go to ... > Anniversary file etc. 
This will open the folder where your personal anniversary, special day data (called 
'holidays') and options files are kept. 

 

 

THE JOURNAL  

If the pointer has turned into a letter J and you click over a date (the black text) in 
the diary you will open a page of the daily journal where you can write your most 
intimate thoughts for that day - or just complain about your boss! 

If there is already an entry for that day there will be a 'J' by the side of the date. If 
you open this you can still add more thoughts to what is already there. If there is no 
journal entry for that date then one will be generated when you click the date.  

You can see existing entries in the journal by clicking over a date with a 'J', or by 
selecting Journal Entries from the View menu. 

Journal data is encrypted as it is saved so cannot be read in a text editor. 
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PRINTING 

Owing to limitations within the development environment of In My Diary, printing is not 

available in the native Linux version of the program. It does work as normal when using 

the Wine emulation. 

Printing Diary events 

You can either print A4 portrait pages of events in ‘Agenda’ list format (either 
including or excluding blank days), or 171 x 95mm sheets in ‘Week on two pages’ 
format (as in a paper personal organizer). You access these from the File menu > 
Print diary or from the printer icon on the top bar. In the window that opens, click 
over the format you want to use.   

Week on two pages:    Agenda view: 

        

Agenda list format can print anything from a few days worth of entries to the whole 
diary. Anniversaries and special days are NOT printed when in this format. The text of 
each event is printed in its entirety. Repeating events will included for the number of 
months set in the Options window (repeats in Agenda view). 

171 x 95mm format can print up to one year’s worth of entries at a time, or select a 
range of months within that year. If you need to keep a paper organizer, you then 
only need to reprint the months where changes were made. The text of each event is 
printed in its entirety but if the text is too long to fit into the available day space it is 
continued on auxiliary pages which print at the end of the normal run. This is also true 
if there are too many events on one day to be shown in the normal day space.   

Crop marks and hole-punch guides can be included or excluded.  

Events, anniversaries and special day notifications use the same font set for the on-
screen diary, although you can set a different font size for event text.  

The 171 x 95mm format pages are intended to print back-to-back and if you have a 
duplex printer this should be set to flip on the short edge. If not then you should print 
the odd numbered pages and then re-feed the paper to print the even sides.  

You should set your printer to print at 100% size and, based on my test, the two sides 
once cropped should align and be fit your organizer correctly. If you find the pages are 
over or undersized slightly, you can make small adjustments to the print size by right-
clicking in the Print Diary selector window and selecting an increase or decrease as 
needed. 
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Printing from Contacts 

Although there is no direct means to print Contact information in a dedicated form, 
there are a number of systems available within the program to allow the export of 
data in a form that can feed other systems. For example: 

You can print from the window that lists all contacts from the View > full address 
list menu. You can also export the data to excel from here. 

In the Contacts window the Edit > Copy data menu allows selected fields to be 
placed on the Global clipboard so it can be dropped into other programs. 

Label printing is the one dedicated form of Contact data printing available in the 
program.  This is described in more detail in the contacts section. When printing labels, 
to select the contacts for which you wish to print labels, make sure the ‘Select for 
printing labels’ box is ticked. If there is any text in the Label Name field of your 
contact then this is the text that will appear on the first line of the label. 

 

PASSWORD PROTECTION AND ENCRYPTION 

The program can use three different passwords for access. These allow restricted 
access to 

1. The whole file 

2. Journal entries 

3. The Password Manager. 

Setting the first two is optional but the third is always required. The general password, 
journal password and Password Manager password can contain international 
characters and symbols so any words in the languages available in InMyDiary should 
be usable. However, the overall encryption key has restrictions (see below). 
Passwords can contain multiple words and can be of any length.    

Initially the program does not have any passwords set. If you would like to use a 
password for your main diary one can be set or changed from the Options menu. To 
cancel password protection make your password nopassword (note, no space) or 
click the Use no password button. You should be aware that if you have a password 
in place, and have set up startup alarms (as described below), the password will be 
required before a startup alarm displays.   

Journal data is always encrypted so no one can read it by opening your journal folder 
in a text editor, but you can also set a journal password so that, even if your diary is 
open, the journal cannot be accessed without a password (which is independent of 
your main password). Then, the first time you attempt to open your journal in each 
diary session you will be asked to give the journal password. You will also be asked to 
do this again if you change the journal password during a diary session. As with the 
main password, to cancel the journal password make your password nopassword. 
Setting and changing this password is from the options menu. 
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You can encrypt your data files by selecting the Encrypt diary data option from the 
General Options menu. If you include a personal key (made up from words or random 
symbols) this will be used as part of the encryption process so, for example, another 
user on your computer could not open your data into their copy of In My Diary. Only 
characters 32 to 126 (what you can type on a UK keyboard) are allowed in 
the key.  

It is important to be aware that if you save a file in encrypted form which includes 
a personal key, that key will need to be active in your options settings in order to 
reload the file. If it is not (for example, you saved a file with one key, and later 
changed the key without saving the file, or you have had to reinstall your Options file 
for some reason) as the file loads you will be asked to give the encryption key. If you 
have forgotten this key I am able to recover it for you and there is an option to send 
me a request by e-mail using the I can't remember, please help button just below 
the key field. Really, once you have set a key there should normally be no reason to 
change it so this problem need not arise, but the service is there if you need it. I 
would ask that if you do send a recovery request e-mail, you make a small (or large!) 
donation to the development of In My Diary. This can be done from the Downloads 
page here, and the PayPal e-mail address should be the same as the e-mail address 
you use to send the recovery request.  
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HOW TO SYNC YOUR DATA BETWEEN IN MY DIARY AND 
GOOGLE CALENDAR 

Firstly, it is important to understand that fully automatic bi-directional synchronisation 
with other calendar apps is not possible with In My Diary. However, from version 3.5 
syncing automatically FROM Google calendar is now an option and feeding changed 
data back to Google Calendar is very straightforward. 

You must of course have a Google Calendar account. The way you then use that in 
conjunction with In My Diary can vary as described below.  

The key to setting In My Diary’s relationship with Google calendar is the Google 
sync setup window accessed from the Google Cal sync button in the General 
Options window.  

 

Firstly, before any syncing can take place, you will need to find your Google Calendar 
Private Address. You will probably need to do this from your computer, not from a 
mobile device: 

1. Open your Google calendar (https://calendar.google.com). If you are not 
currently logged into Google you will need to add your email address and 
password. 

2. The calendars you have in use are listed down the left side of the page (you 
might have to click over My calendars if you don’t see any listed there). You 
may have several or just one depending on your earlier choices. Hover over the 
name of the calendar with which you want to sync, and click the icon (currently 
three vertical dots) that appears to the right of the calendar name. 

3. Select Settings and sharing 

https://www.google.com/calendar
https://calendar.google.com/
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4. Under the heading Secret address in iCal format copy the address there and 
paste it into the top text field in the window shown above (under Google 
Calendar Private Address:) 

You have now told In My Diary which Google calendar to sync with, and you have a 
number of options for how to use this. Your choice will affect which checkboxes to tick. 
However, there is another thing you should do now since you may need this later.  

5. Returning to the Google calendar, click the left facing arrow near the top of 
your page (or click the browser’s back button) 

6. Click the 6-pointed cog settings menu icon at the top right of the page and 
select settings 

7. Copy the URL address of the page that now opens. It is probably similar to the 
one in the bracketed example in the window shown above. 

8. Paste this URL into the lower of the two text fields in the window shown above 
(you will need to tick the 4th checkbox in order to access the text field. You can 
un-tick it once this is done). 

Syncing Options 

1. I want to keep my diary data on my local machine but also have my Google 
calendar data load when I load my usual diary file. 

If you want the Google calendar data to load with your own diary data then tick the 
Sync with… checkbox. If you are only really interested in the future events in your 
Google calendar then you should tick the Only sync future events checkbox. This 
will reduce the time spent syncing. Your Google calendar can be checked 
automatically every ‘n’ minutes if you add a number to the ‘and then every…’ box. 
Make it 0 to cancel the automatic recheck.  

2. I want to keep my diary data on my local machine but be able to add Google 
calendar data easily. 

If you don’t want the Google calendar data to load automatically as your diary opens 
but want to access it during your diary session you should un-tick the Sync with… 

checkbox. Then, to load your Google calendar data you should click the  icon (or 
select File > Sync from Google calendar). Please note that the menu item just 
mentioned will only be available if there is an address added in the Private Address 
text field described in point 5 above. If there is no address, an unreachable address or 

no internet access you will also get an error message when clicking the G icon. 

Once again you may or may not also want to tick the Only sync future events 
checkbox. 

3. I want to keep my diary data on my local machine but be able to look at my 
Google calendar entries in In My Diary and decide whether to add them. 

This works exactly as described in either options above, but you would need to tick 
the Sync as ‘additional’ diary checkbox. This will add your Google calendar but the 
text will be grey, can be switched off if needed from the additional diaries menu, is 
not saved if you save your current diary, does not generate notification alarms and 
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does not display multi-day vertical colour bars. You can convert additional diary 
entries into a current diary entry by clicking over the event and selecting OK.   

4. I want Google calendar as my only data source with no local data kept on my 
machine. 

Starting with a blank diary file, you could set In My Diary to load your entire chosen 
Google calendar when the program opens. This will allow you to read your Google 
calendar within In My Diary and make any changes or additions to it as needed. Once 
you have finished using the diary you would want to send any changes or additions 
back to your Google calendar so these can be accessed by your other platforms 
(tablets, phone etc.) and be loaded into In My Diary the next time you open it. By this 
method you no longer keep a ‘local’ diary on your computer but rely entirely on 
Google calendar for your data. Your setting for this should be: 

 

Add a number (in minutes) if you want In My Diary to keep re-syncing with Google 
Calendar.   

 

 

To send your data from In My Diary to Google calend ar: 

If you use the fourth option (above) you will definitely need to send your data back to 
Google calendar but, which ever system of syncing you use, you will very probably 
want to send any changes or additions you make in your diary back to Google 
calendar so that everything is kept up to date. Unlike loading data from Google 
calendar this is not automatic, but you do this from File > Sync to Google calendar 
(if you have made no changes or the checkbox is not ticked then this menu option will 
be unavailable) and the following actions will result: 

1. Providing you have the Save InMyDiary changes to desktop…. Checkbox 
ticked and you have made some additions or alterations to your data, this will 
create a file on your desktop (called IMDchanges.ics) to be sent to Google 
calendar 
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2. If you have added an address to the Google calendar settings address text 
field and have internet access, then your Google calendar should open at the 
General Calendar Settings page.   

(When you close In My Diary the previous two paragraphs also apply). 

If the Google calendar is set to open in 2 above:  

1. Click Import & export 
2. Click over Select file from your computer and find the IMDchanges.ics file 

on your desktop.  
3. If you have more than one Google calendar, select the one you want to sync 

with under Add to calendar 
4. Click Import, and after a little while you will get a message telling you if the 

import has been successful and how many events have been copied. 
5. Select the Back arrow to return to the calendar and see the new events. 

If things don’t seem to work as you expect (for example, entries are showing different 
times in Google and In My Diary, events are not repeating correctly, you are getting 
events duplicated) then check the following things: 

• Is the time zone set correctly in both In My Diary and Google Calendar? 
• Have you set the correct Daylight Saving time change over in Special Days?  
• Do you have the correct setting for Export UTC time in Options > General 

Options? This option should normally be ticked. 

If you have checked these things and you are still not getting trouble-free transfers, 
then there is probably a problem with the way In My Diary is interpreting iCal data 
sent from Google. I have tried to write programming code to be as comprehensive 
and all-encompassing as I can, but there really are SO MANY possible nuances in the 
syntax of iCal data and, hey, this is a free program and I like to have a life too, so I 
just can’t be sure I have accounted for everything likely to be thrown at the program! 
You can help here be sending me the iCal file that seemed to cause the problem, with 
an explanation of the error, and with your help we can possibly track down a scenario 
that I have not expected and, in solving it, no doubt help future users of the program. 

Early warning settings are exchanged between In My Diary and Google calendar.  

The Appendix gives a little more information about what In My Diary reads and writes 
related to iCalendar files for those interested.    

 

IMPORTING AND EXPORTING iCal AND vCard DATA  

In My Diary can import and export iCalendar (.ics) files and vCards. This allows In My 
Diary to be synchronised with other calendars (for Google calendar see here) such as 
Outlook Calendar and iCal on the Mac, as well as a means of synchronising two or 
more In My Diary files. 

An .ics file can be imported into In My Diary simply by dragging it to an open diary 
page, or alternatively, from the File menu. Multiple selected files can be imported 
together. When importing you will be asked if you want to import highlighted dates, 
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although this will only give a result if you are importing data from an ics file which 
originated from In My Diary.  

Other diary files can also be imported for viewing by dragging the file to an open diary 
page, but the file is not merged with the existing data, but is rather 'layered' over it 
and can be switched on and off. See here for a better understanding. 

Exporting an iCalendar file starts from the File menu (File > Export > iCalendar). From 
the small window which has now opened, you can then export your diary data in one 
of three ways. Two methods are always available - All Diary Events (every event in 
your diary will be exported) and Use Date Range (the window will expand and the 
events between the dates you set in that window will be exported).  

Exporting one or a small number of events 

The third option in the export window, Use Export list, enables you to export a single 
or group of selected events from anywhere in your diary.  This option will be greyed-
out unless you have added some events to the export list. You can add an event to 
the export list by right-clicking over the event in your diary and selecting 'Add event 
to export list' from the menu that opens. The export list will be deleted after you 
complete an export or when the program closes, or you can delete the export list by 
right-clicking over any event and selecting 'Clear Export list'. 

Highlights and anniversaries are not exported when you export by means of the 
export list. 

Exporting Anniversaries and birthdays 

When exporting ALL diary events or events within a date range, you also have the 
option of exporting anniversary information which will then appear as individual ALL 
DAY events in the receiving diary, with the correct anniversary or birthday age 
appropriate for each year shown (if you have set it to show in IN MY DIARY). You can 
also export JUST the anniversary information, and this is useful if you want to export 
to, for example, a Google calendar that keeps just your birthdays or annually 
repeating events.  

Please note that it is ONLY the anniversaries and birthdays held in In My Diary’s 
anniversary section that gets exported. If you have set birthdays in your Contacts 
section to display in the diary, they will not be exported by this method. You would 
need to export your contacts as a vCard and import them into Google Contacts for 
these to be imported, and in that case they would be placed in the Google ‘Birthdays’ 
calendar for your account.  

Also be aware that if you export an iCal file which includes anniversaries and then 
import it back into In My Diary, the anniversaries are not imported as single events 
since that would duplicate the entries created automatically by the anniversary section.  

      

How event times are dealt with when exporting and i mporting 

The time ‘stamp’ that is allocated to an event’s start and finish can either be exported 
as an absolute time, based on Coordinated Universal Time (UTC), or simply stamped 
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with the time shown in your diary. The difference is that when set as UTC the 
exported time will take into account the time zone you have set in Options > General 
Options. If, for example, you export an iCal event about a video conference set for 
12noon in Britain and you send it to your colleague in France with whom you are to 
have the conference, they will import it into their Diary as 1.00pm, which means that 
both parties will get to speak to each other at the correct REAL time, and one won’t be 
still having lunch somewhere. This is the default setting when the program runs and is 
probably the most useful option. You must of course make sure you have the correct 
time zone set in Options for this to work properly. You can either set your time zone 
manually or let the program automatically read zone information from your computer. 

However, if you untick the export UTC Time tick box (in General Options), In My 
Diary will then stamp exported events with the local time shown in YOUR diary 
regardless of your location (but see below).  

  

Daylight saving time 

Information about DST is neither imported nor exported from In My Diary, but the 
time stamp of an event IS affected by the Daylight Saving Time settings you have in 
place in Special Day data, so an event set for 10.00am in summer will be given a 
time stamp one hour earlier, in addition to any time zone adjustments as described 
above. This also applies if you have chosen not to export UTC time.  

The decision not to read and act on any Daylight Saving Time embedded in an 
iCalendar, but rather rely on the settings within In My Diary is really based on the 
shear complexity of satisfactorily reading and interpreting the vastly different ways 
Calendar programs write such information (read this to get a better understanding of 
the issues) - there is no foolproof way of being sure your intentions will be read. The 
downside of relying on internal settings to fine tune your imports and exports means 
that if you are exchanging data with someone who is in a place where the Daylight 
Saving change takes place on a different date from your country there may be a week 
or so where the times of events would be unreliable.       

 

Exporting and importing Highlighted date data 

You also need to decide whether to export highlighted dates. This is selected by 
default and, although other programs will ignore this feature, it won't do any harm 
either.  If you are exporting all diary events or a date range of events you can also 
export only day highlights (no events) from the selected period. If you import 
highlights, please note that it is not the actual 'colour' that is imported, but rather its 
index from the current palette when the file was exported. (The index means the 
numbers from 1 to 10 of the colour range you can set.) For example, one file might 
have light blue as the colour set as colour 1 of its user selected palette, but another 
might have light green. Any dates exported from the first file to the second that use 
highlight colour 1 will show as light green even though they were blue when exported. 
Also, if the exporting file has more colours set (a more active index range) than the 
importing file, any index numbers found that are higher than those in use in the 
receiving file will be reduced until an active one is found. That sounds a bit 
complicated but, for example, if you have 7 colours set and used in the file to be 
exported but only 3 in the receiving file, colours 5,6 and 7 will become colour 3 when 

http://icalevents.com/2613-what-every-developer-ought-to-know-about-timezones-wrt-calendar-files/
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imported. These limitations are in place so that the receiving file does not have its 
colour palette and description altered by an import (which would be confusing - 
holidays might suddenly be marked as something less desirable!) and to avoid days 
that were highlighted in the exporting file not showing when imported because no 
colour has been set for that index number.   

For those interested (or frustrated by failed expectations!) the following features of 
diaries are imported and exported: 

1. Date of event, start time and finish time. (Events periods cannot span over a day 
break) 

2. The subject of the event. (When importing, if the DESCRIPTION does not begin with 
the same text as the SUMMARY, they will both be integrated into a multi-line diary 
event.) 

3. Details of repeating events providing they are within the parameters available 
within In My Diary (currently repeat after an assigned number of days, or on the same 
date at varying monthly intervals, on a particular day on a particular week of the 
month, on the last day of the month - for ever or until a finish date is included). 

The following features (when exported from In My Diary) will only be imported into 

another open In My Diary - other programs will ignore it: 

4. Whether the time of an event should display in the diary 

5. The number of early warning days set 

6. Any highlighted backgrounds to dates. 

Currently only VEVENTS (diary data) are imported and exported. When exporting, this 
will not include data generated by the Anniversary section or from birthdays in the 
Contacts section.  

vCards can be imported  either by dragging the file to the diary window, or from 

the File menu. Multiple selected files can be imported together. If a record for a 
contact is already found you will be given the option to import or bypass. 

vCards can be exported  either as individual records (Click the icon in the top 

right-hand corner of the Contacts window or select export 'Export vCard' from the File 
menu in the Contacts window) or containing all your contacts (from the File > Export 
> All contacts as vCard in the main diary window). 

vCard headers read are N:, FN:, ADR;[any type but one type only - 7 fields]:, TEL;[if 
CELL is found then data added to mobile field otherwise the main telephone field]:, 
BDAY:[yyyy-mm-dd, yyyymmdd and yyyymmddThhmmss(Z)]. EMAIL;:, NOTE:[multi-
line input, subsequent lines starting with a space], CATEGORIES:, URL: 

The ADR field and NOTE field can also read QUOTED-PRINTING encoded fields. 
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IMPORTING AND EXPORTING TO/FROM EXCEL 

 

From the Contacts window you can export either ALL your contacts, or those that 
have the 'Select for printing labels' box ticked. From the View menu select either of 
the choices there, and from the list that opens select the Export menu and then either 
'Export All contacts' or 'Export ticked Contacts' as desired.   

When the excel file opens it will create a temporary format to display the data as 
clearly as possible. If you want to preserve this format you will need to save the file 
as an Excel Wordbook, but the native data is Tab delimited and that is how it will be 
preserved if you don't use Save As.. 

The fields that are exported are ref (used for internal sorting), forename, surname, 
Label, Address 1-4, Postcode, telephone, mobile, Email, notes, and relating to 
birthdays - dob (date), early warning (Y or N), number of days early warning, show 
birthday in diary (Y or N) and the categories that apply to the contact. 

Importing from excel 

If you want to edit this data while it is open in excel so that it can be imported back 
into in My Diary, the file should be saved as a Tab delimited file. To import it, open 
the Contacts window in In My Diary and drag the file's icon to a clear space (not an 
edit field) in the Contacts window. You should get a message telling you that the data 
has been imported. If you get a message saying that that file cannot be imported you 
probably did not save it as a Tab delimited file. Reopen the excel file and resave it as 
Tab delimited. 

If you want to add a new entry to the open excel file, give the entry a reference 
number that is not already in use and put that in the ref column. Then add as much 
data as you are able using the formats already there (birthdays must be in the format 
dd/mm/yyyy but the divider can be / or - (not a space).     

If you want to import Excel contact data that did not originate from In My 
Diary  (perhaps from another PIM or where you have created a file yourself) then 

there are certain points to watch- 

1. The first column must be called ref and should contain unique numbers ranging 
between 1 and 3000. In My Diary stores contacts by numbering them as they are 
added, from 3000 downwards. If you want to add new data to the contacts you 
already have, first make sure you are using reference numbers that are not 
already in use. To find the first free number, either right-click over the Contacts 
window and select "First free contact ref." or open the View > Full Address list from 
the Contacts window and make a note of the lowest ref number in use. Make sure 
your new entries use numbers that are lower than this. They don't have to follow 
exactly in sequence (numbers will be reassigned sequentially once you import the file) 
but just need to be below the lowest number already in use.   

2. The other column headings should be labelled forename, surname, Label, address1, 
address2, address3, address4, postcode, telephone, mobile, Email, notes, dob, 
e/warning, days, showb/d, c1, c2, c3, c4, c5, c6, c7, c8, c9, c10, c11, c12. They can 
be in any order and a file does not need to contain all these fields. Any fields in your 
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file with other headings will be added to the 'notes' entry for that contact (since there 
is nowhere else for it to go) separated by a ";"  and you can decide what you want to 
do with that data after importing.     

  

VIEWING MULTIPLE FILES  

 Importing other files to merge with your existing data has been explained above, but 
from version 2.88 it is now possible to load other diary files into an open diary and 
view the data, but at the same time keep it separate.  

The 'added' diary entries are shown in grey, and their data is not 'live' (ie. it will not 
generate any due alarm messages). 

To add other diaries to view in an open diary, either drag any .ads diary file to your 
open diary or load it from File > Import > In My Diary file. The name of the file will 
then be added to the Added diaries menu. You can tick or untick items in this menu 
so you can choose to view or omit the data. 

If you want to copy an event that appears in an added diary to your 'real' diary, just 
click over the event, then select OK. This will move the event to your diary, and you 
can also change other aspects such as time, early days warning etc, in the usual way. 

If you no longer need to see an added diary, open the Added diaries menu, hold 
down the Ctrl key and click over the name of the diary to remove.  

Contacts in the additional diaries are NOT imported by this method, but NOTES are. If 
there is a conflict with an existing note name the note will not be imported.  

 

 LOADING AND CREATING NEW LANGUAGE FILES  

The language files supplied with In My Diary have been very kindly produced by users 
of the program.  

New versions of the program may include new language files or corrections to existing 
ones, but there may also be times when a new language folder is made available 
between program issues. To load a new language folder, select Load new language 
folder from the bottom of the Language menu. This will open a small window and you 
should drag the new folder to the window. This folder MUST be called lang. It 
should consist of folders (named as the language to display in the program) and in 
each of those folders a text file called “current.txt” which is the language file. If the 
folder passes inspection, you will be invited to import it to replace your old language 
folder. IT IS IMPORTANT TO UNDERSTAND THAT THE REPLACEMENT lang 
FOLDER WILL COMPLETELY REPLACE YOUR EXISTING FOLDER and any 
languages not present in the new folder will be deleted. Access to your language 
folder is possible from the File menu on the main page (Go to… > language files) so 
you can do a bit of moving around of language folders if you want to make sure you 
preserve a particular folder after an update. 
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If you would like to create a language file of your own then this is possible by 
following a few guidelines. The easiest way to create a new file is to use the IMD 
Language translator which is available from the Language menu. Using this will help 
to ensure that the file you create maintains the correct format and is not corrupt. 

There are three menu items in the Language menu that potentially open the Language 
editor and they appear under a separating line at the end of the languages list. Not all 
three options will be available: 

If you have the English version of the diary in use, the only option 
available when first using the editor will be Create new language file. In 
this case, a new version of the English text will open and you will need 
to first add the name of the language for which you are creating the 
translation before you can start to translate or save your work. You 
might also like to add your name as the translator although this is not 
mandatory.  

If you have a language other than English in use, in addition to Create 
new language file you will also be able to select Edit current language 
file and, in this case, the translated file will open and you can correct 
any errors you have found. The effects of saving the file are stored 
temporarily and will not overwrite the ‘real’ file until you select FINALIZE 
and SAVE.  You will also need to reselect the language you have edited 
from the Language menu once you have finalized the file in order to see 
the changes to In My Diary. 

If you have already started to edit a language and not FINALIZED it, the 
only option available will be Open draft language file. If you decide you 
no longer want to edit this file you can enter the editor and then from 
the File menu select Delete draft translation. That will leave the 
translator able to open a new file to edit. 

You do not need to complete a file at one sitting. If you do not produce a translation 
for every lookup code and finalize the translation file, the program will use the English 
version for any messages or headings that do not have a translation.  

It is VERY important that you save any translations you have done somewhere safe 
other than the app.data/InMyDiary/lang folder. This is because the lang(uage) folder 
will always be overwritten when you do a program update or reinstall In My Diary for 
any reason. This is to allow for new ones files and corrections, so you will need to add 
your own file again after any updates (that's why you need to keep a copy safe). If 
you want to send your file to me  I will include it in the official release so this last step 
would then be unnecessary. 

If you ever need to open and save a language file other than in the proper editor, 
please note the following points: 

1. The first line of the file MUST be IMD:In My Diary Language File: 

2. The second line should be #version:<the language> 

3. The third line should be #translated by:<the translator> 

mailto:inmydiary@maydaymusic.co.uk
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Any other lines that begin with # or are completely blank will be ignored by In My 
Diary. 

 

Using the language editor: 

Click a row and the English text will appear in the ENGLISH text field. It is also copied 
to the GLOBAL CLIPBOARD at the same time so you can drop the text directly into an 
external text area (maybe a translating app). If you are doing this and the app you 
are using lets you select all text in the translated area, do Paste from clipboard and 
that will place the translation in the translated text field. 

If you want to include the use of Google translate (which also helps generate special 
characters) you should tick the box Selecting a row launches Google translate. 
You also need to click over the small window (Google language code) and select the 
language to which you are translating. This will add the necessary code. As you click 
over a line of text, this should now launch the Google translate web page ready filled, 
and all you need to do is and copy the translated result to paste back into the 
language editor, and then make any corrections if necessary. If Google translate does 
not launch or there is an error then you may need to edit the constant part of the URL 
for Google translate. You can edit this from the Edit menu.   

Just closing the window will save your work in the editor but you can also save it from 
the file menu. FINALIZE and SAVE moves the new or edited file into the main ‘lang’ 
folder and deletes it from the temporary editor. Your created language or edits are 
then visible in the diary.   

 

HOW TO GET ALARMS TO SHOW WHEN YOUR COMPUTER 
STARTS UP 

On Windows Vista, 7, 8, 10: 

Windows 10: 

First, in the lower-left Search the web and Windows box type %AppData% and 
press Enter 

Windows Vista, 7, 8: 

First, click the Start button in the bottom left of your screen. In the Search 
programs and files box type %AppData% and press Enter  

Then all versions: 

2. In the new window open the Microsoft folder 

3. In the new folder select Windows, then in that folder select Start Menu, then in that 
folder select Programs and finally select the Startup folder.  



 45 

4. If you are using the standard version, open the In My Diary folder in the My 
Documents folder (but make sure you can still see the open startup window).  

If you are using the self-contained version of the program then open the IMDiary 
folder so you can see InMyDiarySC. 

5. If you are using the standard version, right-click and hold the diary file you want to 
run at startup (If you are using the self-contained version right-click and hold 
InMyDiarySC), and drag it into the startup window. 

7. Select Create shortcuts here.  

  

 

On Windows XP 

1. Right-click on the Start button 

2. Click Explore 

3. A window shows the contents of the Start menu 

4. Go into Programs, and then open the Startup folder 

5. If you are using the standard version, open the In My Diary folder in the My 
Documents folder (but make sure you can still see the open startup window).  

If you are using the self-contained version of the program then open the IMDiary 
folder so you can see InMyDiarySC. 

6. If you are using the standard version, right-click and hold the diary file you want to 
run at startup (If you are using the self-contained version right-click and hold 
InMyDiarySC), and drag it into the startup window. 

7. Select Create shortcuts here. 

  

On Mac OS 10.4+ 

1. Log in as the user who wishes to have a login item or as an admin user. 

2. Choose System Preferences from the Apple menu. 

3. Choose Accounts from the View menu. 

4. Click the name of the user. 

5. Mac OS X 10.4 or later: Click the Login Items button. 
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6. Click the "Add {+}" button. 

7. Navigate to the documents folder (or wherever your diary file is) and select it. If 
using the self-contained version you should open IMDiaryM and select InMyDiarySC. 

  

MOVING ALL MY DATA TO A NEW COMPUTER  

If you are using the self-contained version (on any operating system) then just copy 
the program folder (IMDiary, IMDiaryM or IMDiaryL) to a flash drive or disc, and copy 
it to the new computer. It's as simple as that. 

If you are using the standard (fully installed version) then it is a bit more complicated. 

Moving from a Windows XP computer to Vista, Windows  7/8: 

1. Run the program on your existing XP installation. 
2. From the menu -  File > Go to... select 'Documents (In My Diary)' 
3. At the top of the window that opens you will see the folder trail (most likely 
C:\Documents and Settings\< your user name>\My Documents\In My Diary) 
4. Delete the end of the trail to leave only 'C:\Documents and Settings\< your 
name>\My Documents' and you should then see the 'In My Diary' folder 
amongst your other documents. 
5. Save this folder to a flash drive or disc 
6. From the menu -  File > Go to... select 'Anniversary file etc.' 
7. At the top of the window that opens you will see the folder trail (most likely 
C:\Documents and Settings\< your user name>\ApplicationData\In My Diary\ 
codes) 
8. Delete the end of the trail to leave only 'C:\Documents and Settings\< your 
user name>\ApplicationData' and you should then see the 'InMyDiary' folder 
amongst the other folders 
9. Save this folder to a flash drive or disc 
 
On your new computer: 
1. Install the program from the website or from a previously saved installer. 
2. Run the program. It will create an In My Diary folder in your documents 
folder and an InMyDiary folder in your AppData folder. These will of course be 
brand new so will need to be replaced with the data you saved from XP. 
3. From the menu -  File > Go to... select 'Documents (In My Diary)' 
4. At the top of the window that opens you will see the folder trail - 
<yourusername > My Documents > In My Diary 
5. Click over 'My Documents' and you should then see the 'In My Diary' folder 
amongst your other documents. 
6. Delete (or rename) this folder and replace it with the 'In My Diary' (note the 
spaces) one you saved from XP 
7. From the menu -  File > Go to... select 'Anniversary file etc.' 
8. At the top of the window that opens you will see the folder trail - 
<yourusername > AppData > Roaming > InMyDiary > codes 
9. Click over 'Roaming' and you should then see the 'InMyDiary' folder amongst 
your other folders. 
10. Delete (or rename) this folder and replace it with the 'InMyDiary' (note NO 
spaces) one you saved from XP 
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Moving from a Vista, Windows 7/8 computer to anothe r similar: 

1. Run the program on your existing installation. 
2. From the menu -  File > Go to... select 'Documents (In My Diary)' 
3. At the top of the window that opens you will see the folder trail - 
<yourusername > My Documents > In My Diary 
4. Click over 'My Documents' and you should then see the 'In My Diary' folder 
amongst your other documents. 
5. Save this folder to a flash drive or disc 
6. From the menu -  File > Go to... select 'Anniversary file etc.' 
7. At the top of the window that opens you will see the folder trail - 
<yourusername > AppData > Roaming > InMyDiary > codes 
8. Click over 'Roaming' and you should then see the 'InMyDiary' folder amongst 
the other folders 
9. Save this folder to a flash drive or disc 
 
On your new computer: 
1. Install the program from the website or from a previously saved installer. 
2. Run the program. It will create an In My Diary folder in your documents 
folder and an InMyDiary folder in your AppData folder. These will of course be 
brand new so will need to be replaced with the data you saved from your 
previous installation. 
3. From the menu -  File > Go to... select 'Documents (In My Diary)' 
4. At the top of the window that opens you will see the folder trail - 
<yourusername > My Documents > In My Diary 
5. Click over 'My Documents' and you should then see the 'In My Diary' folder 
amongst your other documents. 
6. Delete (or rename) this folder and replace it with the 'In My Diary' (note the 
spaces) one you saved. 
7. From the menu -  File > Go to... select 'Anniversary file etc.' 
8. At the top of the window that opens you will see the folder trail - 
<yourusername > AppData > Roaming > InMyDiary > codes 
9. Click over 'Roaming' and you should then see the 'InMyDiary' folder amongst 
your other folders. 
10. Delete (or rename) this folder and replace it with the 'InMyDiary' (note NO 
spaces) one you saved. 

 

BACKING UP YOUR DATA 

There are two backup systems available from the program. Internal backups will copy 
just the diary files you are using to a local folder (these are automatic when you save 
a file) and a remote backup facility that copies ALL your data (Journal, Options, 
Password manager data and diary file) to a place you specify in the Options > General 
options window.   
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Local Backups  

Every day you save a new version of any of your diary files a backup of the file before 
it was opened is placed in the backups folder. You can see this from View > Backups. 
Only ONE backup per file is saved per day and it will be as it was the final time you 
opened it on that day. They are organised into Year folders, then month folders 
(numbered) and then in date order. In the standard version of In My Diary you can 
simply double-click any of these backup files to open them. In the self-contained 
version, if you have never opened a diary backup file before you will first need to tell 
the file what should open it as follows: 

Open your backup folder from View > Backups and select any backup file - it doesn't 
matter which. Double-Click the file and you will get a message from Windows to tell 
you that Windows can't open the file. Choose 'Select a program from a list of 

installed programs' and click the Browse button in the window that opens. You will 
then need to navigate to your IMDiary folder, open the folder and select 
InMyDiarySC.exe. The browse window will close and take you back to the program 
selector.  Make sure 'Always use the selected program to open this kind of file' 
is ticked and confirm your choice.  

You should then be able to open any backup diary in future by double-clicking over it.  

Remote Backups  

Firstly you will need to specify the location of your remote backup destination. This 
should obviously be somewhere other than the computer on which you are running In 
My Diary, or at the very least on a different physical disc drive. A cloud storage facility 
would be an obvious choice. Once you have made your decision, drag the intended 
folder to the Remote backups field in the General Options window.  

Backups can be made manually as required from File > Remote Backup > Backup 
now (this will not be available to select unless you first set a destination as described 
above). When you select this, ALL your data will be copied to a folder called 
IMDiary_backup in a date-stamped folder (dd_mm_yyyy). There is also a file called 
paths.txt which contains a list of the full paths from where the folders and diary files 
were copied, so that, in the event of a problem, you can replace any corrupt files in 
the correct location with their backup. 

Automatic remote backups can be set for every ‘n’ days from File > Remote Backup 

> Automatic settings. Please note that automatic backups are assessed and 
performed a few seconds after a diary file is loaded and running. This is to avoid any 
conflict with startup procedures.   

TROUBLESHOOTING 

  

Known issues: 

Dragging files (ics, vCard etc) to import them into the Linux Wine based version does 
not work, but you can import files from the File menu.  
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Exporting contact details from the address lists (Contacts > View menu) is not 
possible from the Linux Wine version, and will also not work on any version unless you 
have an Excel-type spreadsheet program installed.   

The main window can occasionally open with zero height in. Adjusting the window size 
(dragging the bottom right corner) and saving the file should normally enable it to 
open correctly next time, but if this problem becomes too persistent you can, from the 
Options menu, set the window to open always at the default size. 

Printing - is not possible from the native Linux version. On other systems, at the 
moment, only diary data (not anniversaries or contact birthdays) gets printed, and 
only the first occurrence of a repeating event will be printed. This may change in later 
editions. 

  

Exporting from RiscOS organizer - There seems to be a bug in version 2.1x of 
Organizer (and possibly earlier versions) where Organizer is exporting incorrect colour 
information so the work around to avoid importing anniversary data will not work. 
Please see the Organizer page if this affects you. 

Owing to some restrictions within the initial program development, repeating multi-
day events will only show the coloured bar for NEXT due repeat.        

I can see small marks (or other bits of text) under neath some entries 
in the diary, or the bottoms of the letters in my e ntries seem to be 
missing.  

This is caused when the point size of your chosen font does not suit the space 
allocated for event text and was correctable from version 3.16 onwards so you need 
to update to at least this version first. 

Go to Options > General Options, under FONT CHOICES click the Events tab. If 
the problem is that you are not seeing the bottom of your letters then either reduce 
the font size (in the size setting) or increase the boundary setting until the text 
appears normal (you will have to come out of the Options window and turn a dairy 
page at least once to see the changes). 

If the problem is that small marks appear under the entry you are actually seeing part 
the second line of your entry (or an internal reference in the case of repeating events). 
Proceed as above but this time either increase the font size or reduce the boundary 
setting to solve the problem.    

 

The program seems to freeze for a while when I chang e something 
or save my diary.   

This was a problem for some people prior to version 3.16 and was particularly 
noticeable when the number of your diary entries and contacts had grown to result in 
a large file (perhaps over 400 KB), and if you had autosave enabled. 

http://www.maydaymusic.co.uk/inmydiary/org.php
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The saving procedure was changed in version 3.16 and so this should not normally be 
a problem for most people anymore. If you have an extremely large diary file you 
might still notice a short freeze when saving or at other times if autosave is enabled 
and particularly if you have Encrypt diary data enabled.  If this causes you concern 
then you can try turning off backups, cancel autosave, turn off encryption or a 
combination of these three.       

Error Messages: 

Usually the error message will give you some options for coping with the error. The 
program will only shutdown if the problem cannot be solved with the program running, 
and in this case the error message should include an error code. Please email me to 
let me know about this, including the error code, and I will advise you further. 

"There is a problem with some startup data. Press OK to reset your Options, 
Special days and Anniversary data"  

If you see this message, some part of the Options data has become deleted or 
corrupted. If you select OK to this message, your Options, Special day and 
Anniversary data will be reset to the state it was when you installed the program. 
Your old Options etc. will be copied to a folder called "InMyDiary(corrupted)" which is 
in your Application Data (XP), AppData (Vista, W7) or Application Support (OSX) 
folder. If you are not sure how to find this folder then email me because your Special 
day and Anniversary data is probably still OK and you can copy these back to your 
new folder. 

You can force the program to reset the Options, Special day and Anniversary data by 
holding down the H,L and P keys as you start In My Diary. If you select OK to the 
startup message, please note that the existing data will not be backed up. 

 I cannot find your language file …. 

This is most likely to occur where more than one person uses the standard version of 
In My Diary on a single computer, each with their own account. It is now ESSENTIAL 
for each user to install the program from their own account in order to have 
independent control of which language files are available. 

Pages turn quite slowly and it takes a little while for a new event window to 
open when I click over a date 

This seems to be a problem particularly noticeable on Linux, although older slower 
computers on other systems might also have this issue. Although the problem was 
vastly improved in version 2.80 and 2.82, if this is still something you notice, you can 
increase the operating speed by not setting any birthday warnings in the contacts 
section (add them to anniversaries instead). There must be none set at all for the 
benefit to be seen. 

I cannot find your default file 

When the program is opened by clicking InMyDiary.exe directly (or a shortcut to it) it 
will always open the default file specified in the Options window. This is initially called 
‘diary.(ads) although you may have changed it. If the file is not there you will get a 
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message (I cannot find your default file) and have the option of opening the folder 
where the default file should be or quitting the program. Accept the option to look in 
the default folder. 
 
If what you expected as the default file IS there, then In My Diary is looking for a 
different diary file, which may have got changed or set in the Options window.  
Double-click the diary.ads file to run it and, once running, go to Options > General 
Options to confirm the default diary file. Just drag the diary.ads file to the text field 
alongside 'Default diary file'.  
 
If it isn't there (through moving or accidental deletion) then you would need to 
replace it. If you have been using the program and saving at all, there will also be a 
folder called backups and you can enter this to find the most recently opened diary. 
Double-click that to run it and then save it as 'diary.ads' in your documents > In My 
Diary folder.  
 
When you are using the standard version it is often better to run the program by 
double-clicking the diary file rather than the program shortcut. That way it doesn't 
matter whether your default file is there or not. You can always make a shortcut of 
your diary file and place that somewhere convenient (for example, the desktop). Diary 
files can be placed anywhere, and can be called whatever you wish if you run them by 
double-clicking. You will not get this message if you normally open the program by 
double-clicking a file that you have saved. 

Program won't run at all when I double-click an .ads file or the InMyDiary.exe 
file. 

This is most likely due to a problem with the program trying to look for updates as it 
loads (if you have that option selected). Holding down the Ctrl and Shift key as you 
start the program should solve this issue.  

If you get a message that the program must close down before it has even 
opened, there will probably be an issue with your Options, Anniversaries or 
Special day data which does not even allow the error message (mentioned 
above) to be called. You will need to hold down the H,L and P keys as you 
open In My Diary and this will reinstall the Options, Special day data and 

Anniversary data. Unfortunately you will lose the data associated with these 
files but you will at least be able to run the program. 
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APPENDIX 1 

iCalendar components understood and written 
yyyy =year: mm =month: dd =day: n =any number: n(n-n) =number range: dn =two letter 

code for day name (MO,TU etc) 

BEGIN:VCALENDAR 

    BEGIN:VEVENT 

 DESCRIPTION: 

 SUMMARY: 

 LOCATION: 

UID:  

DSTAMP:, DTSTART:, DTEND: (with…) 

yyyymmdd (or) 

yyyymmddThhmmss (or) 

yyyymmddThhmmssZ 

RRULE: (with…) 

  FREQ=DAILY; (with…) 

INTERVAL=n; (defaults to 1 if not seen) 

UNTIL=yyyymmdd[time ignored]; COUNT= n; (last one seen applies) 

         OR    

FREQ=WEEKLY; (with…) 

INTERVAL=n; (defaults to 1 if not seen) 

UNTIL=yyyymmdd[time ignored]; COUNT= n; (last one seen applies) 

         OR    

  FREQ=MONTHLY; (with…) 

    BYMONTHDAY= (with…) 

n; (on this day of the month) 

-1; (last day of the month) 

  INTERVAL=n; (defaults to 1 if not seen) 

UNTIL=yyyymmdd[time ignored]; COUNT= n; (last one seen applies 

              OR    

    BYDAY= (with…) 

n(1-7)dn ;  (example 2TU – 2 nd Tuesday of the month)  

-1dn ;  (example -1WE – last Wednesday of the month) 

-1: Last day of the month  

(n.b. minus numbers other than -1 are not read) 

(n.b. INTERVAL is ignored if with ‘BYDAY’)   

UNTIL=yyyymmdd[time ignored]; COUNT= n; (last one seen applies) 

    OR  

  FREQ=YEARLY; (with…) 

INTERVAL=n; (defaults to 1 if not seen) 

UNTIL=yyyymmdd[time ignored]; COUNT= n; (last one seen applies) 
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EXDATE: (with..) 

 yyyymmddThhmmss  if at a set time or… 

 yyyymmdd if an All Day event 

 

 Multiple exclusions can be linked by a comma 

 (eg. 20180201T153000,20180215T153000) 

Or are read as separate EXDATE: messages each with a single 

exclusion   

   

    BEGIN:VALARM 

ACTION: (with..) 

DISPLAY (Display is the only option sent or read) 

TRIGGER: (with..) 

-PnDTnHnMnS (In this format the time unit chosen will be 

based on the nearest whole unit, so –P1DT0H0M0S would show ‘1 

day early warning’ in the diary but –P1DT0H20M0S would show 

‘1460 minutes early warning’. Seconds are always ignored.  

OR 

 -PnD (example –P10D would give a warning 10 days early) 

OR 

 -PTnH (example –PT2H would give a warning 3 hours early) 

OR 

 -PTnM (example –PT30M would give a warning 30 minutes early) 

 Only TRIGGER values beginning with – (minus) are read. 

Notifications at a specified time (in the format 
20170317T133000Z) are not read, neither are post-ev ent alarms. 

 

DESCRIPTION: (“Early Warning” is exported out but imported 

descriptions are not used by In My Diary.) 

    END:VALARM 

    END:VEVENT 

    BEGIN:VTODO 

  DESCRIPTION: (or SUMMARY: whichever is seen last) 

UID:  

DSTAMP:, DTSTART:, DUE: (with…) 

yyyymmddThhmmssZ 

  COMPLETED: 

     END:VTODO 

END:VCALENDAR 

 

Currently other components are ignored but others may be implemented in future 

versions of In My Diary. 
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APPENDIX 2 

Importing Excel files to Contacts – Field names und erstood 
 
The following column headings will be recognised when importing an excel file: 

Indented headings are alternatives. If both are present the last one seen will be used. 

HEADING   PURPOSE   EXAMPLE / POSSIBLE VALUES 

Title    Name prefix    Mr. Mrs 

Forename   Any non-family names  John Mary 

Surname   Family names    Smith-Weston 

Address1   Name or number and street  The Willows 

         34 Broad Street 

Address2   Further address details 

Address3   Further address details 

Address4   Further address details 

Postcode   Digital address form   W1A 1AA 

Telephone   Landline number   020 75…etc.  

     Telephone number 

Mobile    mobile number 

     Mobile number 

 (Use spaces in telephone numbers to stop excel stripping leading zeros) 

Date of Birth   Separate with – or /    12-03-2000 

     Dob         12/03/2000 

     Birthday 

e/warning   early warning  of birthday  Y, N or blank  

     early   early warning  of birthday  Y, N or blank  

days    number of days early warning  1 - days left this year 

showb/d   display contact’s birthday  Y, N or blank 

Notes    Any other text you want 

Email    obvious 

    e-mail address 

Label  Will be used when printing labels in preference to forename surname  

c1    Categories that the contact  Y, N or blank 

c2    has joined.    Y, N or blank 

c3         Y, N or blank 

    etc to…… 

c12         Y, N or blank 
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UNINSTALLING THE PROGRAM  

From 26/08/2012 the standard windows installer has been altered slightly. This does not 

affect the versions for MacOS or Linux, or the Self-contained versions. Therefore the 

section below (concerning the standard Windows version) only applies to installations 

made from this date onwards. Earlier Windows installations behave in a similar manner to 

the MacOS one when uninstalling. 

  

Removing the self-contained version  (for any platform) is simply a matter of 

deleting the IMDiary folder. All data connected with the program should be in that 
folder. There is no data in the registry. 

Removing the Standard (not self-contained) version:  

Uninstalling a standard Mac and Native Linux version is slightly different from the later 
Windows version. While the Windows version now removes ALL data from the 
appropriate folders allowing a completely clean re-installation, you must locate the 
documents and Application Support folders manually as described below and delete or 
rename these in order to allow a clean re-installation. 

 

Windows 

Use the system's 'Uninstall or Change a program' or 'Add/Remove Programs' facility to 
delete In My Diary from your computer. Everything that was added to your computer 
at installation time will be removed AND the entire contents of the 'In My Diary' folder 
in your Documents folder. This will include any new diary files you have saved in there 
and all your backups. If you do not want to lose these, please make a copy of the 'In 
My Diary' folder before starting the uninstall process. 

 

Mac 

Just drag the 'In My Diary' folder in your applications to the trash. This will remove 
the program but NOT your personal data (diary files, options, passwords etc.). To 
remove these you will need to go to your Documents folder and to the 
<user>/Library/Application Support folder to find folders named 'In My Diary' and 
'InMyDiary'. If you are wanting to make a clean re-installation (for example, in the 
case of a corrupt password) but not lose the data in these folders, just rename them 
before re-installing.   

 

Native Linux 
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Click on the Software Center icon in the Launcher, or open the Dash, and search for 
Software Center. 

When the Software Center opens, click on Installed Software. 

In the Installed Software section, find In My Diary in the list or search for it. 

Select it click Remove.    

You may be asked to enter your password. After you have done that, the Program will be 
removed. This should not take very long. As for the Mac, your options data and diary data will 
be left untouched. To remove these also you will need to go to your Home folder and delete 
the InMyDiary folder there. You will also need to show hidden files and delete the InMyDiary 
folder in the .config folder. That will remove all options and password data. 
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